Drobo

Drobo 2nd Gen critical firmware update, failing

Hello,
I have had the original Drobo, 2nd Gen for more than a decade. It worked w/o trouble 'till now testifying to the quality… However after a series of power outages it died. I need my data so I got second hand identical unit. Upon plugging it in it showed older firmware 1.3.7 that would not work with my disks from Drobo having firmware 1.4.2. I thought that this would be simple… Although “Check for updates” automatic update failed, I easily found firmware 1.4.2, properly extracted needed file and tried “Manual update” manual update failed (it started than crashed reporting to check Drobo support, no other details). As this is an old firmware and old unit I tried different Drobo Dashboard versions on older hardware I have. Original first attempt was from MacOS 10.14, latest Drobo Dashboard. I tried from MacOS10.5.4 w DD 2.1.2 and from Windows XP w DD2.6.4 - same end result. I am attempting update with no drives inserted. The unit is connected via USB cable and I tested it with other spare disks, works 100% fine, just won’t update firmware. I suspect some trivial incompatibility but what? Drobo support just pointed me to FTP site that has less resources than the main download page… Please help, I really need that data… Thanks!

Since the original post I have done following as well, still with no result: On MacOSX 10.5.4, Windows XP and Windows 7 I started with the oldest Drobo Dashboard version that would install (1.8.4 and earlier wouldn’t install on any of these systems), reset empty Drobo connected via USB and attempt both automatic “Check for updates” firmware update and manual firmware update with the 1.4.2 firmware I downloaded directly and properly extracted. After multiple fails I would upgrade to level up Drobo Dashboard, all the way to the current issue and repeat the process with each. Up to 2.2.4 DD tries to download automatic update and fails, more recent versions just fail “Check for the update”. All version note that the firmware update is available (and correct one)! However, none can apply it.
Drobo in question still works perfectly with HDs up to 1TB capacity each but reports anything larger as damaged disk and can’t deal with it (as expected, firmware update is supposed to address exactly dealing with the larger drives).