Drobo

Drobo (2G) crash during rebuild

Background: So I have a 2G Drobo attached to my G4 MDD Mac server (10.5.8) with the latest firmware/dashboard. I recently decided to upgrade the storage from (1.5t/1.5t/750g/750g) to (2t/2t/1.5t/1.5t). The first drive upgrade went without a hitch - I just popped it out, and 2 days later everything was back to solid green. After the first drive had been swapped, everything seemed good. Solid green lights, Drobo Dashboard showed expanded capacity.

Problem: When I tried to upgrade the second drive, I saw that it too would take roughly 50 hours to rebuild. After a few hours, I noticed AFP was being slow. I restarted AFP a few times, and when that didn’t help, I reconnected to the server later to check the progress and saw that the dashboard was telling me that no Drobo was connected.

Things I’ve tried:

I first waited a few days, to see if the drobo would finish the rebuild so that I could power it down nicely. It’s been 9 days now, and the drobo still is blinking orange/green (rebuild). I rarely hear disk activity, although both green lights at the bottom above the blue capacity meter are solid on.

I started reading, and figured out that disconnecting from the computer was not fatal in and of itself. I rebooted the server and tried to reconnect, but Drobodashboard still shows “No Drobo Connected.”

Both my Drobo and my Mac are on UPS power supplies, so I’m pretty sure that it wasn’t a power hiccup that caused this.

Situation now:

It seems like there’s no alternative to yanking the power, since I cannot get the drobo to connect to my server.

Given that, am I better off:

a) leaving the drives as they are in the drobo and powercycling it

b) replacing the last drive I added with the that I took out and powercycling, in hopes that the Drobo will not have altered data on the other three drives, and that replacing that one will make everything whole.

c) something else, although that seems like the only two options since waiting hasn’t worked.

If a rebuild or relayout is taking days instead of minutes or hours, and the disks are even spinning down during the process, then it does appear that there is a problem.

Drobo or DroboPro is in a confused state, indicating that it is rebuilding on the one hand, while not actually rebuilding on the other.

Please try the following steps to impose a full reset without compromising data:

  1. Shut down your computer.
  2. Remove your USB/FW cable.
  3. Remove your power cable.
  4. Unseat all drives, one at a time.
  5. Restart your computer
  6. Launch Dashboard.
  7. Plug in USB/FW cable
  8. Plug in Power.
  9. Once dashboard connects to drobo, go to Advanced Controls > Tools Tab > Standby Button under commands.
  10. Remove USB/FW cable.
  11. Remove power.
  12. Reseat all drives, one at a time.
  13. Plug in USB/FW cable.
  14. Plug in power cable.

I’ve followed the steps you listed, twice using different Macs. Each time, the drobo comes back up after its boot sequence, and enters its rebuild mode. Then the Drobo dashboard quits a few times over the next hour before it dies for good and refuses to recognize the attached drobo. Between the end of the bootsequence and then, data is readable and appears to be intact.

After the second hard reset sequence, the drobo stopped flashing the orange/green rebuild lights, and now shows only a single orange light in the power-light position.

I would recommend opening a support case.