I have a Drobo 1st gen I got in 2012.
It is incredibly slow.
At best, I have a sustained transfer of 30 MB/s.
It is connected using a FW800 to Thunderbolt adapter.
I often get weird file corruptions where the PSD files will not be opened and my large RAW files are also corrupted.
Usually running DiskWarrior fixes that.

So I’m attempting to backup a vital directory that is about 350GB in size. The transfer starts out at the stately 30MB/s but after an hour or two, it slows right down to 3…yes THREE MB/s.
It isn’t frozen because the files are still transferring but that speed is completely unacceptable.

Drobo Dashboard told me to update the software. I did just that. It promptly told me that the new software did not work and I had to restore the old software again.

I am at my wit’s end.

Anyone have any ideas?

can i ask if it suddenly (recently) became slow, or if it has always been slow for you?

usually the write operations can cause new files being written to the drobo to go slow, when the drobo becomes fairly full. can you pass us some more information about what drives and space you are using?

is the 30gb folder currently on the drobo, and you are trying to read it (to copy it) to another drive?

im not too sure about the software update, but have you tried connecting it via another cable, just in case the current cable got damaged somehow, and have you tried a usb cable to see if there is a difference?