Drobo

drive replacement causes perpetual reboots

I have a first gen Drobo (USB) that has worked well for a while now, but I started having problems with it recently.

Background: I had a pair of 1TB drives (Western Digital) and a pair of 2TB drives (also WD’s) installed in it until yesterday. I did notice after installing the last 2TB drive that it rebooted and went into protection mode twice in as many weeks, but it had calmed down and worked fine since. I did perform a disk check using Disk Utility (Mac OS X.6), but it found no problems.

Yesterday I swapped one of the 1TB drives with a 2TB drive and watched it go into protection mode as expected. The surprise came roughly an hour later when it started rebooting almost constantly. I at first figured the new drive was bad, so I swapped it with the original 1TB drive when it was down. It was over an hour later when it started rebooting again.

At this point I’m panicking and getting desperate. I looked up the knowledge base and found the recommended procedure to deal with the constant rebooting problem (http://support.datarobotics.com/app/answers/detail/a_id/102), but that didn’t help either even after repeated attempts. As a last hunch last night, I swapped the same 1TB drive with the 2TB drive I tried earlier and re-ran the procedure.

That appeared to work for a while, but I found it down again this morning (meaning: no lights except for a flashing green power indicator light, not mounted in the OS, Dashboard showed the unit was there, but no drives installed). A quick power cycle brought me back to where I was yesterday. So far it appears the data is still on the unit (it is hard to confirm the data is OK though, for it won’t stay up long enough; but it still thinks it has 3TB of data on it), but it again is rebooting constantly.

I unplugged it this morning when the reboot started (solid red drive lights; all blue lights on) out of fear that it will eventually corrupt something and I have my boss looking out for a replacement unit. Hopefully I can simply stick these 4 drives in a replacement and have it work as expected, but either way I have to ask …

Am I missing anything? Any other ideas as to how to rescue this robotic friend, or does it have to be put down now because it somehow deduced the zeroth law of robotics? :wink:

What firmware is your drobo on?
What kind of 2TB drive did you insert? (was it a 4k sector drive)

Firmware is 1.3.6 [1.253.25784].

All drives are WD Caviar Greens. The pulled drive was actually an odd-man-out (a 1TB WD Caviar Black, model WD1001FALS), the replacement 2TB drive is a WD20EARS. There are already 2 other WD20EARS installed, the remaining 1 TB drive is a WD10EADS.

Please open a support case.

I also had problems with WD20EARS. A single HD of this type won’t work. It causes a “boot loop”. Combined with a WD6400 they worked side by side without trouble…