Dorbo 5D doesn't mount after FW upgrade 3.2.2

I just upgraded to the latest firmware 3.2.2 and now my 5D won’t mount anymore. I tried several thunderbolt and usb connections but nothing happens. I even powercycled the Drobo and the MacBook, reinstalled the Dashboard, disconnected the HDDs…

The Disk Utility doesnt recognize the Drobo either. Right now i have no chance to access my Drobo in any way.

Does anybody has an idea what to do? I tried to google my problem, and also googled the firmware before upgrading, but couldn’t find any problems with it…

Am i the only one with this kind of problem?

Im running OS X 10.11.2 on a mid 2015 Macbook Pro 15" Retina, 2.8 i7, 16GB

Would be great if anybody has an idea. Thanks!

hi prfilms,
can you remember if the drobo restarted on its own after updating the firmware?
also can i check which version of dashboard you are using? (while i would have thought that the das drobo should still be accessible even without dashboard, the release notes mention using 2.7.1 so just to check)

i also just posted some steps on a very similar issue and maybe you could try them as well to see if it works?
eg this particular comment post:

I just had the same problem. I have dashboard 2.7.0. Drobo 5D[hr]
My DROBO was working perfectly before I received a message to upgrade my firmware. After updating it, it will not do mount. It powers on and I’m left with an small orange light in the lower left front of the device. I am a professional photographer teach photography. I have two DROBOS. I have used them over 10 years. I have been fortunate to never have any problems till now. I phone DROBO tech support about this issue and they would even talk to me about it since my warranty ran out just a few months ago. I have got to get to my pictures quickly. Guess I’ll have no choice but to pay them. My problem with all this, was my DROBO was running fine before I downloaded their firmware upgrade. As soon as I get back up and running, I will be looking into doing something different. DROBO, you just lost a bunch of customers! and one very loyal one.

Yellow power light is standby, try changing the cable or port the Drobo is plugged into.
You really can’t predict when a cable or port will go bad.