Does anyone else's 5N drop / keep dropping network connection?!

I was over the moon with the 5D that I purchased a year ago, to use as a CrashPlan Backup Drive.

So pleased that I then decided to purchase a 5N which should have been good enough to use as a network file server for 10 users.

But ever since then, our working days have been plagued by the 5N constantly but randomly dropping everyone’s connection to it on the network.

Has anyone else had the same experience with a 5N? If so, is there ANY solution to this nightmare situation?

No issues with mine, been rock-solid for years. You could have a network or cabling issue.

Hmmm… This was one of my first ports of call. But we’ve got a fairly ‘standard’ network, with multiple Macs, printers and storage devices on, running through enterprise level switches/router - and never (for many years) had any other devices that just keep dropping out like the 5N constantly does.

I have read a few posts about 5N dropping out, so wanted to see if any is still having the same issues or if there is a way to resolve this issue?

Having the same issues here, we have it mapped as a drive letter to our work files and it drops out constantly throughout the day on the network and sometimes loses the mapped network drive altogether. once the connection is re-established its ultra quick but its just this problem of losing connection and it taking so long to reconnect again (about 30 seconds) We’ve tried a number of things like tweaking network settings but nothing seems to work?

We may need to see the Drobo diag, as a standard rule of practice:

  • You should be using the Ethernet cable supplied by Drobo
  • You should be on a gigabit connection
  • Connect to a different port on your switch or router

As a test, you can directly connect the Drobo to the Ethernet port on your computer to see if the same issues occurs, this will tell us if your issues is with your network or the Drobo or the drives.

It looks like setting the Drobo 5N to DHCP instead of a static IP and rebooting my router seems to have fixed this issue. Not at all sure why this would be the case but, if i find anything else i will update this post so others can use this to help them if they run into this themselves.

I am having a similar issues with my 5n that has been working fine for years. It drops connection while playing videos (or just disconnects randomly) and then reconnects again. I have tried a new LAN cable, new port on router and on a switch, same issue. I am on the latest version of firmware and dashboard. I have even re-updated the firmware just in case manually and still the same issues is happening. The odd thing is if i do a ping -t to the static IP of the drobo it keeps replying even though the mapped drives disappear and the dashboard does not see the 5n until the service on the drobo resets then everything comes back on after a few min. I have noted that in the SMB diag logs it shows “Oplock break failed for file” and it lists the video i am playing. Have tested multiple files and it happens on any file within 20 min. Sometimes as little as 2 min into the video it craps out. I have tested the unit plugged into the PC directly and that did not disconnect after an hour of playing a video. Not sure what could be the issue. If anyone has seen this issues or has any ideas i can test please reply as i have run out of any real ideas and am going a bit nuts trying to fix this.

[2016/07/30 17:31:31.928667, 0] …/source3/smbd/oplock.c:699(oplock_timeout_handler)
Oplock break failed for file removed_file_name.mkv – replying anyway

Thanks for any help.

hi koleion,
im not 100% sure, but if the connection remains ok when connected directly to your computer, then it seems that it is something about the network which is causing problems or a potential conflict in some way…

when you have the drobo connected to the computer, is it using a particular network cable (which is also the one you use to connect the drobo to the network/router?) if so, then maybe there is another cable further down the chain / network that is having an intermittent fault (which you could maybe swap the cables around to retest that one directly) - or maybe some settings in the router had changed (possibly after a router firmware update that might have taken place, or by a power cycle of the router that somehow wiped some settings?)

Thanks for the reply. It seems that there was an issue with my router giving out the IP i had set the Drobo as and this was why it was disconnecting, or at least that is what i think was going on. I have had no issues as of now with the DHCP set. sometime soon i will set it to static again with an IP out of the DHCP pool and test again to see if there is any change.
As to your question i had swapped out the LAN cable two time before, but i use another one when i plugged it direct to the PC. i am still using that one as it was working fine and i wanted to leave the last working cable connected just in case. so there is a small chance that was part of the issue too. not 100 % sure but its working now and that is all that i can ask for. If i find anything else out i will update this post.

ok thanks koleion, thats cool its working again :slight_smile: