Drobo

Disk Warrior reports disk malfunction and grays out "Rebuild"

When I run Disk Warrior on my Drobos (I have two, both 4 bay Firewire models), it always reports that there were disk malfunctions and ends up graying out the “Rebuild” button. On some rare occasions, it has allowed me to rebuild the directory but those are few and far in between. This also happens to my friend’s Drobo Pro.

Why does this happen? How can it be fixed? Thanks.

Try USB and boot from the Disk Warrior CD.

I just tried your suggestion and it made absolutely no difference. Exact same results.

The bigger question is why you need to run disk warrior at all, what happened? I’d the same issue last week. I gave up and reformatted.

@bnewport We do recommend that you regularly check the integrity of your data. For Mac’s it is either disk utility or Disk Warrior. I honestly recommend Disk Warrior. I see disk utility fail too many times.

@elai72, please open a support case.

Good bye all, its been emotional.

I am selling my drobo, and obviously the next person might want access to the forum, so do I need to like unregister or something?

There is no un-register option.

I supposed we could just delete your user profile.

[quote=“Jennifer, post:5, topic:1123”]@elai72, please open a support case.
[/quote]

I don’t see any links to open a support case. Do I need to call? Thanks.

http://support.datarobotics.com/app/utils/login_form

I’m having the exact same issue. I contacted the DiskWarrior folks and they suggested that I’d take a look at my logs.

The log is full of entries looking like this one:

I used TechTool Pro to check the drives for bad block and haven’t found any.
Since I’ve had issues in the past with the drobo drive spinning down the disks (multiple drobo drives on multiple Mac), I suspect it might be related.

Any suggestion?

Corentin

Please open a support case so we can look at the diagnostic file from your drobo.

I’m on my way…
Thanks Jennifer,

Corentin[hr]

Done! and FYI, it’s ID: 100505-000038.

Corentin

If anybody is interested, the logs eventually revealed that one of the disks was experiencing time outs.
If it’s in the logs, I’m a bit surprised the software didn’t warn me at some point, but at least I now know what was the source of all that trouble.

Corentin

It wasn’t enough to trigger the drobo to report it as failed, but enough for disk warrior to have issues with it.

Apparently Disk Warrior is more sensitive then the Drobo.

Thanks for the clarification.
Aren’t the time outs a bad sign for the health of the drive though?
It sure was the first time ever I saw such message in DiskWarrior…

Corentin

I’ve seen diagnostics where a drive timed out once in 2 years, that isn’t a issue. Thats why the drobo wouldn’t mark that drive as failed. It had one little hiccup. But it does look at how many timeouts in a certain time period. When it reaches that threshold, then the drobo does mark that drive as failed. If I’m not mistaken I was the tech on your case. It had some time outs and some bad blocks/sectors on 1 drive. Not enough to worry drobo but apparently enough to worry disk warrior.

I see. Once again, thanks for the clarifications Jennifer,

Corentin