Disk disappears

I’m setting up a new Drobo 5N. I’m seeing some surprising behavior with one of my disks: a couple of times now, the Drobo has simply stopped seeing it. The indicator light is blank (or red, if it’s sitting in the next “available” slot and the Drobo wants another disk); the Dashboard reports the drive bay as empty.

If the disk failed or something, I would expect a flashing red light. But instead, Drobo acts as if the disk doesn’t exist.

First occurrence: The disk was in Bay 1, with a second disk in Bay 0. I powered the Drobo down and carried it to another location. When I powered it back up, it could see only one disk. I popped the disk out of Bay 1, tried to put it back in with no success (maybe I was just impatient), and tried Bay 3 instead, where it showed up after a minute or so, triggering a data protection run.

Second occurrence: The disk was in Bay 3, with another in Bay 0. I installed a third disk in Bay 1 (don’t remember if I did this live or after a shutdown). I had three green lights. A few minutes later, I get a “Drobo detected drive(s) removed” notification, the Bay 3 disk disappears, and the other two go into data protection mode. I reinserted the disk in Bay 3, then restarted the Drobo, and it saw 3 disks again (now all doing data protection).

Is this a known/understood issue? Is there likely to be a physical problem with my disk and/or Drobo? Or maybe this is a strange reaction to a faulty disk?

hi once you have it back to a safe state, and data protection is complete again,
you could try to shut it down and disconnect it,
and to then (with all power off), to remove each drive and reinsert it firmaly in the same place (one by one)
then to connect and power it up etc

it might have been a loose connection which needed reseating (and it was causing problems)

hopefully that is all, otherwise it could be a range of other things:

  • damage to the backplace if bumps encountered during transport etc
  • hard drive issues
  • something else… so lets take it one step at a time.

(if you have enough space and can still access your data though, then it might be good to spend a bit more time to copy the data somewhere else, just in case)

Just happened again. No physical contact this time. After running data protection for 2 hours, the disk suddenly dropped off and I got another “Drobo detected drive removed” notification.

It looks like Paul is right. You seem to have some a poor contact situation going on with that drive. The contact is weak enough that simple vibration from the fan is causing it to sometimes disconnect.

It could be a disk problem or a Drobo problem. One way to tell if the Drobo is the problem is (once data protection is finished) to switch disks around and see if the same slot is causing trouble or if it is the same disk having trouble again.

It’s definitely a problem with the disk. It disappeared from multiple bays, and I haven’t had the problem with any others. I’ve also experienced other errors on the disk when connected to my computer via a USB enclosure. I don’t know if it’s a connector problem or something internal to the disk; and I wish the Drobo produced more meaningful diagnoses; but, whatever, I’m discarding the disk.

hi, if the faulty drive seems to still have problems, which followed it to slot 3, then it sounds like that drive is playing up too…

if you can replace it with another drive (when safer to do so) it will be good…
but more inportantly… are you still able to access your data at the moment?

i think you can, so it would be good to start copying it to another location (dont move it), just in case something else goes wrong in the meantime.

(btw i meant to say backplane above, not backplace) :slight_smile: