Drobo

Delayed Write Failed

I have been using my Drobo S for a year and half. Each week I execute a backup image pgm to backup my system drive to the Drobo S. This weekend, I encountered my first “Windows - Delayed Write Failed” Dialog Msgbox on my Windows XP Pro - Desktop PC whcih resulted in the incomplete backup, by backup pgm. Both the Windows Daolig Box that appeared and the Event Log (event id: 50) indicated that a Delayed Write Failed during trying to save the file to the disk.

Does anyon know what could have caused the Delayed Write Failed to occur ? Has this happened to anyone with their Drobo S ?
P.S. I have been executing the same version of my backup imaging pgm, on a Windows XP Pro - SP3, desktop pc for the past year. The only thing different from when I executed the Backup to the Drobo S, a week ago, was the usual applying of MSUpdates, last week.

… The really strange thing, is that 30 minutes after getting the Delayed Write Failed, I ran my Backup Pgm again and it worked perfectly - no error message this time. As matter of a fact, I ran the Backup Pgm 4 more times in a row and still no error.
… Also, after getting the error (that one time), I had checked the Drobo Lights and they were all green. DashBoard indicated “Drobo Healthy” and “Data Protected”.

So, I have no idea why the error message occurred only that one time.

Questions:

1. Any ideas why this happened and how to prevent it from happening in the future again ???

2. Has this happened to you ?

Hasn’t happened to me, but Delayed Write Failure usually means that the drive didn’t respond to the write request in a timely manner.

This could be because one of the drives “stalled” and Drobo was waiting for it.

You could send your diagnostic log to DRI/Drobo and ask them to analyze it. They should be able to tell you which drive is having an issue.

bhiga,
How many days of access does the diagnostic log hold, before the log entries of activities roll off or are wriiten over, for the day’s activity when my problem occurred ?

P.S. What is meant by "one of the drives ‘stalled’ " ?

Sorry, don’t know how much data the log holds, DRI/Drobo will probably have to answer that one for you. I would imagine it holds a good amount though.

By a drive “stalling” I mean it stops responding to the controller for some amount of time. This can happen for a variety of reasons, but most times it’s due to the drive encountering an internal error (bad sector) and attempting to repair it (copying the affected data to a spare sector and marking the bad one). On drives without TLER (read: all consumer drives), the drive stops communicating until it’s finished with the error correction, which can cause issues if the host system communicating with the drive is expecting a response within a certain amount of time, or wants to handle errors on its own.

bhiga,

I sent the Diagnostic Log to Drobo Support and they replied back that: “we do not see any issues with your hard drives”.

… So, do you think that this was just a Win XP, once in a blue moon “quirk” ?
… You, know the only other thing relatively new in my setup, is my New HP Printer which has a built-in "Flash Drive/PictBridge - USB Port. When my HP Printer is “ON” the built-in USB port is activate and becomes the next available drive letter on my pc. Now, when the printer is Turned OFF, the printer’s builtiin USB port deactivates the the drive letter for it disappears. … Do you think that the printer’s built-in "Flash Drive/PictBridge - USB Port could occassionally interfere somehow and cause some type of conflict that could my “Delay Write Failed” Error to be issued that one time that I got the message ?? (P.S. I have tried many backups the Drobo S, since the 1 time that I got the error msg, both with the hp printer on and off. The Error does not occur anymore.)

Well, it’s a good sign that Support said they do not see any issues.

It might just be a one-time thing.

Normally I wouldn’t suspect your card reader as an issue but I’ve had really funky USB problems in the past, usually due to insufficient USB bus power, so it’s possible that the addition to the mix is somehow to blame.

  1. Do you have any USB hubs? If so, how many ports are they, and do they have their own power supply?
  2. Does your HP printer’s PictBridge and Drobo ever change drive letters?

To be honest, I’m inclined to say it was just a one-time fluke. But it’s still good to check your USB configuration - easy to overload and confuse Windows, especially XP. :slight_smile:

bhiga,

  1. Do not have usb hubs.
  1. Drobo is always my G: drive. And Printer’s USB port is always assigned E:, all the time, it always takes my next available drive letter, after c: (hard drive) and d: (dvd drive), but before my always fixed assigned G: for the Drobo.
    … However, the only thing is that if:
    A. The Printer is powered on first and then the Drobo:
    Disk Mgmt shows — printer usb port as “disk 1” and drobo as “disk 2”.

B. The Drobo is powered on first and then the Printer:
Disk Mgmt shows — Drobo as “disk 1” and printer usb port as “disk 2”.
But, in both above scenarios, drobo is always Drive letter G: and Printer USB Port always E:

OK, thanks for getting the info.

The disk numbering (enumeration order) really shouldn’t matter as drives are accessed by name from the application side.
I was more concerned that one drive was “running over” the other somehow.

Given the combination of support saying there’s nothing wrong with the drives and your subsequent lack of issues, I’d go with “$#!+ happens” and move on with life. :slight_smile:

I agree, thanks.