data transfer slow on drobopro

I have two drobopros direct connect to macbook pro running current os. All of a sudden one of the pros doesn’t write very fast. I can copy off just fine. Not a techie, tried connecting with different cables/ports and usb/fw800. Ran disk warrior. Still no change. Can anyone help?

Is the usage high? More than 80%?

Are all the lights showing green? If not, you may have a bad drive in it.
If so, you can try freeing up some space to at most at 80% or lesser and replace the drive(s), one at a time.

Since you have 2 Drobo Pro units, you could also perform a test to see whether the unit itself is causing the issue.

  • Shutdown both Drobo Pro units.

  • Remove all drives for both units.

  • Insert the disk pack from the affected Drobo to the other one.

  • Reboot good unit with the drives that was originally from the other Drobo unit.

Check whether issue persists.

usage is 82%

Swapped drives into drobo unit that works fine and found same issue. Copy hangs with “preparing to copy” and if it does start copying it takes forever.

Drobo shows all drives green… You suspect a bad drive the cause? How would I isolate that?


Try a slot flush? If you note any one of the drive that causes the unit not to boot up, that could be the problematic drive…

Ran slot flush. Same issue occurs. When I drag/drop to copy to unit it hangs and if goes its extremely slow.

I noticed however, my itunes library is on the same unit. When I add a new video clips of good size (over 1gb) to itunes the transfer speed is just fine and normal.

Would reinstalling firmware help?

Thanks for the help KelvinY

Hmm… I’m not too sure.
If all the drives boot up when performing the slot flushed procedure, they seems to be in working condition, and you probably need not replace any of them yet.

Try closing all applications/tasks/services that may be accessing the Drobo (e.g. Lightroom, iTunes, Final Cut Pro, etc).
And check whether that hastens the copying process.
You can perform a reboot on your computer and close all tasks that starts on boot up. Then try to copy the files.

Sorry, I don’t have any other suggestions to offer should the issue persists. Not too sure whether reinstalling the firmware would help either…