Data Protection Question

I had a problem with i/o errors with a previous Drobo Gen 2, and moved the disk pack to a different Gen 2. It has worked fine for several weeks, but today I got messages of Data Protection in Progress, followed by rebuild complete. This happened two times. Is there any way to know which of the disks was involved? I tried OS X Disk Utility, but it found no errors in the “drive”.

disk utility or others will probably only see the drobo as a collective drive, (or volumes as collective drives) but
if you can have look in dashboard screens, can you see any message near the drive bay slots saying “warning” or “healed” for example?

i/o errors can sometimes happen with a faulty connection cable, but if you had a rebuild then it is probably more likely that a drive had errors. (what you could try, could be to power all down, and discharge your static etc, and with power all off and disconnected, to remove each drive in turn, and to firmly reinsert it again back into its slot, and then once all done, to power all up and see dashboard again for any messages. sometimes a drive will wiggle free a bit, especially of the spring clip/latch is loose, and it could have had an intermittent connection which triggered the rebuild, but do have a look in dashboard 1st when you can as it might help to show a drive which is having problems.)