Drobo

Data Protection in progress for DAYS!

Hi,

My Drobo 2nd gen. is displaying the “data protection in progress” message and all drives in the unit are flashing green & orange.

Two days ago it said there was 72hrs left to go and now, 48hrs later it says there are 127hrs remaining! (oops, now its just gone up to 138hrs!!)

I’ve tried following these instructions: http://support.datarobotics.com/app/answers/detail/a_id/167

But nothing changed.

Reading and writing files still work perfectly.

I have 4 x WD 2TB drives installed

Used: 3.89TB (72%)
Free: 1.54TB (28%)

Total 5.44TB

Any advice gratefully received!

thanks

Jim[hr]
Now it says 43hrs remaining. Im sure it will jump up again though! The progress bar does not seem to work at all.

are you disks actually spinning down or is it still working?

you say you can still read and write - reading and writing during a rebuild will dramatically increase the rebuild time

I agree, stop playing with it.
My unit is identicial to your configuration,(drives are Hitachi. though). Rebuild last night start saying 111- 127 hours. Within 30 minutes the RB time decreased to 90 hours. This morning it is down to 80 hours. You have alot of data on the unit right now. If you need to touch it, copy from it, then the Drobo will allow you to do that. It always gets in the way of the rebuild.

I changed out my only 1.5 TB disk to a 2TB Hitachi that I broke out of its enclosure. Now I have 42TB disks in my Drobo v2, with 3.9TB used.

Hi guys, thanks for getting back…

I’m not actually playing with it, I just tried moving a couple of files to test it after the 48hr period previously discussed.

The computer has no activity on it, it is a mac mini that is literally just sitting there working on the drobo.

It has now gone up from 43hrs to 138 again!

This cannot be right can it?

I saw mine fluctuate over the 3-4 day period, last time. I just let it do its thing.
I won’t tell you NOT to play with it. You can certainly work with your existing files and that is the point that DRI sells, you will not lose access if a drive fails and during a rebuild.
Have you ever done a rebuild before? If you are most concerned about that, then it is advisable to not touch the Drobo.
You have ALOT of data to relay out across the drives. Ignore the fluctuating numbers for now.

If the rebuild is not completed in a total of 4 full days, then I think that you need to get involved. Don’t worry until then. Because there is nothing that you do in the meantime to make this go any faster. And if there is a problem the Drobo, you won’t be able to fix it in the middle of this process.

You can safely sleep the mini. The Drobo will keep doing the rebuild. Once it finishes it will go to sleep itself. Just don’t unplug anything. :slight_smile:

I’m adding two 2TB drives to my second gen with 2.11TB of data (it was 78% full). The first drive took 33 hours to add. Having added the second it is now about 22 hours into the rebuild and the Drob-o-meter says it’ll be another 20 hours. In my experience what the desktop gives are just ballpark estimates. And sometimes they are way off the mark. When I added the first 2TB drive it consistently said 70+ hours but was finished in 33.

thanks again chaps…

one thing i noticed on the mini is that drobo dashboard occasionally shows the drobo as not connected (although it still appears in finder) and then it comes back and shows the pie chart thingy…

is that ok?

Yeah, Dashboard sometimes does that. It’s nothing to worry about. I usually don’t have Dashboard running st all, it’s only when Drobo is rebuilding or being upgraded that I do.

So I left it alone for the entire weekend and suprise suprise, 137 hrs remaining.

I honestly do not believe that this will ever be complete.

It would have been Sooo much faster to rewrite all the data onto the drobo.

The big problem is this drobo is for a client, and they need the data on it. I am supposed to deliver it tonight!

There must be somthing else to do other than just wait while this arbitary timescales jump around. It must be a problem because why would Drobo even bother programming a progress bar if it was utterly useless?

it does sound like it has stalled and is no longer doing any work

Thanks, does anybody know the solution to a ‘stall’?

Contact support. I know it sounds trite but you’ve got a problem that I don’t think any of us know how to cure. The danger to trying anything we suggest is that you will lose all data on Drobo and have to start again. And it’s not a problem easily diagnosed without looking at the logs and knowing the internals.

Jennifer has said retrieving the logs restarts the relayout process, so definitely check with support and follow their steps.
…and if you’re like me, be careful to follow their steps exactly and not run ahead or sideways when you think you know what’s going on - that’s when the real trouble starts! :wink:

thankyou everybody! In the end I just wiped it and rewrote the data… took 48hrs and the data is protected. The drives inside still make a lot of activity noise though, even when it is supposedly idle… in fact it even was making tonnes of read noise while it was blank!!

if you have just put a lot of data on there it will take at least 48 hours to optimise the internal layout[hr]
during which time the drives will seem busy…