Drobo

Dashboard is Not Seeing my FS Again

OK, here we go again. If you remember, I posted the other day about having to switch out my router (Time Capsule). I have temporarily replaced it with an Apple Airport Express Base Station (AEBS). I say temporarily because I will get a new Time Capsule later this week because the original one was still under warranty. After I thought I had solved my issues yesterday, I noticed that my read/write throughputs seemed low (8-9 Mb/s). Since I thought I had solved my router woes, I shut down my FS through Dashboard and reconnected my FS directly to my Macbook Pro. I then ran a AJA test for read/write speeds. Good results, mid-to-upper 30’s Mb/s. I shut my FS down again via Dashboard and shut down my laptop. I hooked the FS back into the AEBS, turned on the FS, and started up my laptop. I’ve been sitting around waiting for Dashboard to see my FS. I have even gone through the trouble of uninstalling and reinstalling the Dashboard software. No joy. Dashboard will not see my FS while it is connected through the AEBS.

Somebody please help.

Thanx in advance.

Is your laptop on wired or wireless connection?

Wired connection.

Strange… DHCP enabled on both your laptop and FS?

Yes. I am on the telephone with tech support right now.[hr]
OK, folks, here is what we found.

I had Jumbo Frames permitted on both my FS and my Macbook Pro. Since I couldn’t find a Jumbo Frames permission or setting selection within the AEBS, I assumed that the AEBS permitted Jumbo Frames automatically. Guess I assumed wrong…you know what they say about assuming…makes an A$$ out of u and me. Long story short, I set both my FS and Macbook Pro to not use Jumbo Frames and voila, my FS is working like a champ.

Word to the wise, do not use Jumbo Frames with an Apple Airport Express Base Station.

I am going to call Apple tomorrow and see if the AEBS does or does not support Jumbo Frames. I’ll try and remember to post what I find out.

Thanx to Jeff at Data Robotics for taking the time to work with me.

Did you try to connect you Macbook Pro and Drobo FS directly without using your AEBS? I assume you see the same behavior.
I’m quite sure that the problem is not the AEBS but the Macbook Pro. The ethernet chipsets in current Macs (except Mac Pro) do not support Jumbo Frames.

Jumbo Frames is one of those fun things that’s all-or-nothing. Having a mix of devices trying to use Jumbo Frames can actually give you worse performance than not having Jumbo Frames at all.

Absolutely. I spent yesterday testing Jumbo Frames, but gave up. It resulted in worse read speed for all my devices.

Without Jumb Frames:
Directly connected to MBP: 50mbs R/W,
Thru AEBS (2007): 22mbs R/W
Thru Airport: W3-7mbs R7-10mbs

With Jumbo Frames:
Directly connected to MBP: W10mbs / R20mbs
Thru AEBS (2007): W10mbs / R20mbs
Thru Airport: W3mbs / R6mbs

It would have been real nice with a faster router since Drobo-FS obviously can work faster than the 22mbs I´m getting.
Does anyone with the 2009 AEBS get any better speeds?

On my Mac Mini I have the same problem as winksuki, Dashboard just says, “Ready for connection”. Finder sees the Drobo-FS, but Dashboard is blind. I too have tried the uninstall/reboot as decribed by DataRobotics. Still no luck…dont know what to do.

Which benchmark tool did you use?

I have a 2009 Time Capsule here and it does not make any difference if I connect my Mac/Drobo directly, via Netgear Gigabit switch or by Time Capsule. Jumbo Frames are turned off here as Macs do not support them.

XBench shows:
Sequential uncached, 256k blocks:
~35 MB/s write, ~60 MB/s read

Random uncached, 256k blocks:
~8 MB/s write, ~55 MB/s read

Make sure you have DDService64d as part of your exception rules for your firewall if you are running 64 bit Snow Leopard. This was recommended by tech support when I spoke with them yesterday evening.[hr]
I don’t know why someone is saying that Mac’s do not support Jumbo Frames. If you go to System Preferences -> Network -> Ethernet -> Advanced -> Ethernet -> Configure and select Manual, one can set MTU to Jumbo Frames.

I do agree that Mac’s do not support Jumbo Frames whilst connected via Airport. If you go to System Preferences -> Network -> Airport -> Advanced -> Ethernet -> Configure and select Manual, there is no option for Jumbo Frames. Even selecting Custom, one can only place a maximum value of 1500.

I use the DataRobotics-recommended AJA System test:
File I/O API: Unix
VFR: 1920x1080 10-bit RGB
FS: 1GB
Disable System cache

With Xbench thru AEBS I get:
Sequential uncached, 256k blocks:
35 MB/s write, 58 MB/s read

Random uncached, 256k blocks:
34 MB/s write, 58 MB/s read

Someone is saying this because someone else at Apple decided to put the Broadcom 5764 Ethernet chipset into current Macs. That chipset does not support Jumbo Frames. :wink:

See MBP or iMac specification for the used chipset and see chipset info here: http://www.broadcom.com/collateral/pg/5764M-PG100-R.pdf

Thanks! Works!