Dashboard doesn't show apps for loading

I picked up a used Drobo 5N. The device seems to be working perfectly and I was happy to not be maintaining my server with FreeNAS. However, I want to install some of the apps, specifically to run CrashPlan for backup. All the docs show using the dashboard to do this, but I do not see an apps nav in my dashboard. Can anyone give me a hint as to what I might be doing wrong?

I’m running the dashboard on Windows 8, so I also wondered if there could be a compatibility issue.

Did you enable Drobo Apps in the dashboard settings?

Dashboard --> Drobo Settings --> Admin --> Enable Drobo Apps

Yes, I did enable it in the dashboard - sorry, I definitely should have mentioned that. Also, dropping apps in the DroboApps share seems to work - at least they are being unpacked on restart.

hmm it might be a bit quirky…
have you tried exiting dashboard, and relaunching it?

and then if you have no apps installed yet, have you tried disabling apps, and then re-enabling it? (+/- a dashboard restart)