Dashboard can't find FireWire drobo gen 2 since upgrading to OS X 10.10.2

Might be a coincidence but Dashboard can no longer find my Drobo gen 2 connected via FireWire/thunderbolt adapter to my late 2014 Mac mini. Was ok before applying 10.10.2. Drobo mounts fine though, and seems to be working ok.

Anything I can try?

I have a Drobo S and started having the same problem yesterday. I am using FireWire and have a Mac mini too. I updated both the Dashboard to 2.6.4, and Yosemite to 10.10.2 yesterday, so I don’t know if one, the other, or both is responsible. My firewall is not blocking the Drobo. The Drobo mounts and I can access my files.

I switched to USB, and have the same problem after a restart - though when I first connected it, Dashboard recognised it. Multiple restarts and it still isn’t recognised.

same here - nice support guy said that they cannot say what is wrong as the unit is out of warranty! - They release software that make unit unusable and they don’t provide support!!

Tried switching to USB, rebooting, etc. with no results. Disappointed at the customer support. Drobo creates the problem with a faulty software update and won’t help. Without the software the unit was behaving erratically and sometimes the contents would not show. I did not want to risk losing my family pictures and videos. I felt I was being forced to upgrade my Drobo S to get the help I needed.

I switched to a Caldigit T4 unit which was more expensive than Drobo, but the device is working flawlessly. For the file transfer I connected the Drobo using the USB cable and the Caldigit using Thunderbolt. No messing with complicated tweaks to make Time Machine work as with the Drobo S. I called the Caldigit customer support with some questions and they were very helpful. You get what you pay for. I also subscribe to CrashPlan for added security.

Dear drobo!
Im done with you
Months of troubleshooting and time wasted
Because you decided to make my drobropro unsuable by Your own software!!!
And now even saying “sorry we dont support drobo pro even if you pay us”

Thanks for sending away your customer! Excelllent job!

Just bought a magnificent synology!
Seriously insane!

Same here. Very convenient to Drobo sup just say: We no longer support you, this is your problem now.

Ok, sooo, in this case, if you just broken our system and support with YOUR software, give us an EASY way to download all old software history, so we can step back one by one until we find one that is working. In OFFICIAL legacy Gen 2 page, it says latest Dashboard for my Drobo is 2.6.4, but that is not right because it was released on Jan-2015 and Drobo Gen 2 was killed (by you) in Dec-2014 (without any notice indeed).

Oh yeah, I’m done with Drobo too… a very bad experience all these years.

Ok, useless answer from Drobo support:
“Your Drobo has reached the end of its product life cycle and is no longer covered by warranty, we can no longer offer support.”

The simple and right answer they should give us:
“Your Drobo has reached the end of its product life cycle, so please use the last supported dashboard for your product and pray to it keeps installing forever on future system releases. Oh, btw, here is a link to your legacy driver: https://dl.dropboxusercontent.com/u/536514/Drobo-Dashboard-2.6.3.dmg

So you have to disconnect your Drobo, make a complete uninstall using 2.6.4 uninstaller, restart your mac, make a clean install of 2.6.3, reconnect your Drobo and restart your mac again.

Now its recognising my Drobo Gen 2 again on Yosemite 10.10.2 (how long, nobody knows). Hope it helps, because Drobo support didn’t!

See you.

Planned Obsolescence is one of the poorest customer service moves of all time. Had the same issue today, noticing my Time Machine backup hadn’t run in the last couple days. Finally got some time to look into it. The most recent Drobo FW update 2.6.4 caused Drobo Dashboard to not see the device any longer. I contacted customer support and was also told that they can’t support my device and it’s a good time to upgrade. BS! My device was working great prior to your update! Didn’t Apple get in some (under reported) trouble for updating the FW that caused the iPhone 3GS and older devices to come to a near crawl? At first they responded that the 3Gs was no longer officially supported. I think they settled prior to losing the lawsuit. Any lawyers looking for a Class Action Opportunity? I’m in! Needless to say, I won’t be buying another Drobo, unless they acknowledge this major blunder and correct it. It’s fine to discontinue hardware support for old products, but if the failure is due to a firmware update, you simply can’t stop supporting it without creating an awful customer experience. If you break it, you fix it! I have always planned on buying a new Drobo when my current one stops working. Not now.

Robinson.Sampa is correct. Use the link to direct download the 2.6.3 driver. Uninstall completely and then reinstall using the 2.6.3 FW. My Drobo is back online again.


Not Happy!

Could you please repost a download link to 2.6.3?[hr]
found it: ftp://updates.drobo.com/dashboard/mac

I can’t see 2.6.3 there, just 2.6.2 and 2.6.4
Here is the link again:
Hope it works now.
See you.

This worked although I dropped back to version 2.54. I will try 2.63 from your download link. I am using a Mac Pro using OS X 10.10.3 beta.

Now its recognising my Drobo Gen 2 again on Yosemite 10.10.3