Drobo

Dashboard can no longer see Drobo 5n2

Dear all,

NB first time post

I have been running my drobo 5n2 for over a year now with very few issues indeed. It sits in the corner of the room running with 5 disks and I have been happily controlling it from the dashboard when needed. It holds work, and personal data and a lot of it valuable for my daily use.
However, since March 2019, the dashboard will no longer see the drobo.
I have I feel tried absolutely everything to fix this on this:

When issue started:
Running Mac OS El Capitan

Updated Drobo Firmware to latest 4.41 (I think) in March.
Updated to 3.42 dashboard in March

Since then to troubleshoot:
Reset the Buffalo WSR router
Updated OS on Mac to High Sierra (cant use Mojave)
Reinstalled Dashboard multiple times and even downgraded.
Taken out Drobo drives and reseated them,

I can ping the drobo from my mac but dashboard will not see it so I believe that the recent firmware has rendered it useless for the time being. Its the only thing that has changed or I ever do on the drobo.
I have also read that there was a change in Security with High Sierra on the OS and I have gone through the process to troubleshoot this as well to no avail. In system preferences/security and privacy there should be a prompt to allow me to see the DD Service and allow access but after multiple installs I have not seen this either, so Apple could also have a say in this too.

If there is someone that can help on here who has experienced this recently please let me know how you fixed it. I would really very much appreciate any advice, as mentioned I feel I have tried everything but suspect this is a communication protocol/network issue between the drobo and the mac dashboard.
Many thanks in advance
Nick

Is your macOS Firewall on? You can try adding DDService64d manually to see if that will help.

  1. Click “Firewall Options…” button
  2. Click the “+” under the list box
  3. Navigate to the following folder: Macintosh HD > Library > Application Support > Data Robotics > Drobo Dashboard
  4. Select DDService64d, then click the “Add” button
  5. While you are at it, click the “+” again, navigate to the Applications folder and select “Drobo Dashboard” and click the “Add” button
  6. Make sure you choose “Allow incoming connections”

After accomplishing the above, reboot macOS High Sierra and launch Drobo Dashboard to see if your Drobo is discovered. You may also want to try configuring the Drobo Discovery Settings in the Drobo Dashboard with the IP address of your Drobo (Add Drobo by IP)

Good Luck!

Thanks for the response. Indeed I have tried all of the above and many other things too and this was not the problem. My issue was deemed to be a faulty NIC on the Drobo and its now being replaced.

Many thanks

Nick