Drobo

Dashboard 3.5.2 + macOS Security Update 2020-006 KEXT not loading

After applying the latest Security Update 2020-006 to Mojave, my Drobo won’t mount and Dashboard won’t find it.
Dashboard says that the KEXT is not loading:
‘Drobo system extension has been blocked by macOS. Please go to “System Preferences >> Security & Privacy >> General” pane and allow the extension to be loaded.’

However, the extension never appears in this pane. So it cannot be approved.

I found that by checking whether or not the KEXT is notarized it is NOT notarized.
I believe Apple is preventing KEXTs from being approved unless they are both signed and notarized.

The loading errors are :
sudo kextutil /Library/Extensions/DroboTBT.kext
Kext rejected due to system policy: <OSKext 0x7fede992f600 [0x7fffa929d8f0]> { URL = “file:///Library/StagedExtensions/Library/Extensions/DroboTBT.kext/”, ID = “com.drobo.SCSI.ThunderBolt” }

sudo kextutil /Library/Extensions/TrustedDataSCSIDriver.kext
Kext rejected due to system policy: <OSKext 0x7ff80b4147f0 [0x7fffa929d8f0]> { URL = "file:///Library/StagedExtensions/Library/Extensions/TrustedDataSCSIDriver.kext/", ID = "com.TrustedData.driver.VendorSpecificType00" }

The lack of notarization is indicated by
e.g.
stapler validate -v /Users/precursor/Desktop/DroboTBT.kext
DroboTBT.kext does not have a ticket stapled to it.

stapler validate -v /Users/precursor/Desktop/TrustedDataSCSIDriver.kext
TrustedDataSCSIDriver.kext does not have a ticket stapled to it.

I tried uninstalling Dashboard 3.5.2 and reinstalling 3.5.0 but the same result.
Neither it seems has notarized the code-signed KEXTs

Drobo will have to issue a 3.5.3 update with notarized KEXTs I think.

It appears I am wrong and they are notarized:

spctl -a -vv -t install /Library/Extensions/TrustedDataSCSIDriver.kext

shows that they are notarized. Probably only Drobo could do a valid staple check.

But the reason they do not load is still a mystery and until they load and can be approved in Security and Privacy General pane I won’t be able to see my Drobo.

This solved my Drobo Dashboard failing to load and Drobo failing to mount.

I had to load the Developer Team ID manually.

I got Dashboard software’s Apple Developer ID (7L83S9698G ) using this:

codesign -dv --verbose=4  /Library/Extensions/DroboTBT.kext
Authority=Developer ID Application: Drobo, Inc. (7L83S9698G)

codesign -dv --verbose=4  /Library/Extensions/TrustedDataSCSIDriver.kext 
Authority=Developer ID Application: Drobo, Inc. (7L83S9698G)

Then I manually installed it in recovery mode (resulting in the KEXT being pre-approved):

  1. Start up in Recovery mode : Command R
  2. open up a terminal session
  3. manually approve the Developer ID by typing:
    /usr/sbin/spctl kext-consent add 7L83S9698G
  4. Hit enter and then restart the macOS normally and the Drobo KEXTs will load , the Drobo will mount and Drobo Dashboard will work properly. (At least until you reset the NVRAM by doing something like a PRAM reset Command P R ).

I spent a couple days reinstalling Mac OS on a computer that had a failed SSD. After installing the new drive with High Sierra and all the updates, I noticed I was unable to WRITE to my Drobo 5D. I can read from it fine.

In the end I restored from a Time Machine backup and the Drobo was working…then I installed the 2020-006 security update - Drobo is stuck Read Only.

I tried what you suggested above and it did not fix things for me. I’m just going to reinstall again and skip the 2020-006 update until Drobo Dashboard updates.

Very annoying to say the least.