Dashboard 2.6.2 compatibility for windows 8.1

Hi. I use Drobo 3rd generation for my storage with other RAID 5 backup server systems.

I just installed Dashboard 2.6.2 for windows. However, it won’t start at all.
First showed black screen and after that poped up error message with “AppHnagB1” problem event.
I can install and start well with Dashboard 2.5.3 or below.
(Unfortuately, Dashboard 2.6.0 or above can recognize my Drobo system.)

Any Idea??

(Dashboard 2.6.0 or 2.6.1 might work. But I can’t get the version anymore in the webpage.)

Thank you in advance.

Works fine for me (but with Drobo S v2). Have you tried reinstalling? What does it say next to the “Drobo Dashboard Service” under “Win-X -> Computer Management -> Services and Applications -> Services”? Is it running?

It is running.
“C:\Program Files (x86)\Drobo\Drobo Dashboard\DDService.exe”

I tried to install and uninstall again over again. *(Even reinstall Windows 8.1 professional X64 genuine for 5 times.)

I tried to install Drobo Dashboard 2.6.2 to 4 different PCs of windows 8.1. ALL OF THEM failed to launch 2.6.2 program.

Interestingly, I can launch 2.5.3 from all of the PCs well. The thing is updating function is not possible in the program.
So I have to find other MSI (install version) program to try other version.

The issue is not related with mother board chipset or CPU or language of windows OS. (I tried many times.)
I think Drobo™ company should know on this issue and deal with it.

Do you have any third party antivirus/antimalware software running there (and on all the other PCs…), by any chance?

It’s a brand new windows pro 8.1 genuine. No additional program. (Even Office 2013.)
I feel frustrated with this issue.

BTW, why dashboard 2.5.3 (works well!) does not support to upgrade to 2.6.2 ?
(Only 2.6.0 or above can recognize drobo 3rd gen.)

Downloading and testing dashboard 2.6.0 or 2.6.1 will help this issue, I think.

im not sure about windows 8, but have you tried rightclicking on the exe to Run As Administrator, in case it requires more permissions?

(btw just saw your pm now) :slight_smile: