Couchpotato errors

A while back I had Couchpotato running perfectly, now I seem to be getting some kind of permission error. Error log is:

[.core.downloaders.sabnzbd] Failed getting queue: Traceback (most recent call last):
File “/mnt/DroboFS/Shares/DroboApps/couchpotato/app/couchpotato/core/downloaders/sabnzbd/”, line 74, in getAllDownloadStatus
‘mode’: ‘queue’,
HTTPError: HTTP Error 401: Unauthorized

The section of Python script including Line 74 looks like this:
# Go through Queue
queue ={
‘mode’: ‘queue’,
log.error(‘Failed getting queue: %s’, traceback.format_exc(1))
return False

I haven’t messed with it at all - so a little confused about whats happening. Anybody out there had a similar issue or can point me in the right direction to solve it?


Are you sure these are not hacking attempts from the outside? This looks like someone is trying to access your web interface and failing.

I just tried to install it and it not working at all. It just wont run.

No…errors seemed to correspond directly to my use. I couldn’t solve the issue, so uninstalled the build that was on there (from Nov 2013) and have installed v2.6.0 from droboports.

The permission error isn’t occurring anymore, but now having issues with the rar extraction…

01-17 14:35:53ERROR[tato.core.plugins.renamer] Failed to extract /mnt/DroboFS/Shares/Public/Downloads/_______.rar: No suitable RAR unpacker installed Traceback (most recent call last):
File “/mnt/DroboFS/Shares/DroboApps/couchpotato/app/couchpotato/core/plugins/”, line 1203, in extractFiles
rar_handle = RarFile(archive[‘file’], custom_path = self.conf(‘unrar_path’))
File “/mnt/DroboFS/Shares/DroboApps/couchpotato/app/libs/unrar2/”, line 102, in init
RarFileImplementation.init(self, password, custom_path)
File “/mnt/DroboFS/Shares/DroboApps/couchpotato/app/libs/unrar2/”, line 79, in init
stdoutdata, stderrdata =‘v’, []).communicate()
File “/mnt/DroboFS/Shares/DroboApps/couchpotato/app/libs/unrar2/”, line 133, in call
return call_unrar([cmd] + soptions + [’–’, self.archiveName] + files, self.custom_path)
File “/mnt/DroboFS/Shares/DroboApps/couchpotato/app/libs/unrar2/”, line 62, in call_unrar
raise UnpackerNotInstalled(“No suitable RAR unpacker installed”)
UnpackerNotInstalled: No suitable RAR unpacker installed

I have specified a path to the unrar in Renamer -> Advanced Settings -> Unrar path: “/mnt/DroboFS/Shares/DroboApps/unrar/bin”
Must be some issue with it though. Any thoughts?

What happens if you set the path as “/mnt/DroboFS/Shares/DroboApps/unrar/bin/unrar” ?

Ricardo is there a special way to install counchpotato. I got it from you site. it installed but when trying to run it it doesn’t run for what ever reason. I have 5n

FML…worked. Thanks Ricardo!

Nope. It installs just like any other DroboApp. Just put the TGZ file inside the DroboApps share and it should work.