Copy error 5N on Mac for large folders

Just got my new Drobo 5N.
Trying to move via Mac running OS X Sierra all the contents from my old DAS RAID setup to the freshly installed Drobo 5N.
Trying to move folders that have 1-2 TB of content. Files on average are 1-10GB.

After an hour or two I get a copy error and have to abort the copy process.
Very frustrating.

Any ideas why this is happening and how I can fix it?

hi heliguy, while i do not have a mac, maybe the following could help you:

  • are you able to try a test, where you copy the data, and paste it onto the drobo (rather than via a move operation?)
    (i mention this because i often have issues on windows, when using “move”, with any device in general not just a drobo, but simply because some of the files were in use or being scanned by antivirus or something else, and the “copy” and “paste” method worked fine, and then once i was happy with the copy, i could then delete the source.)

  • it might be worth checking the overall size of the contents you are trying to move, and then checking to see if the volume or drive letter that you are trying to move them to on the drobo, is having enough free space (but also to compare the amount of free space with what Dashboard is showing you, since it is always possible that the operating system could be showing you more free space, than what you actually have overall on the drobo)

  • also, can i check if the drobo and dashboard are showing you any yellow or red solid lights, if so, that might indicate low overall space being available on your drobo (though it might also depend on what error code was being shown too)

I was actually copying it. My thinking was I’d rather copy and in case the copy doesn’t work, I still have the original data on the source drive.

Ther was plenty of space available on the Drobo, that wasn’t the issue, I was moving A total of 3-4TB to a 8TB Drobo.

All lights were solid green.

I did manage to move the contents over. Had several errors, but in the end managed to move everything over.

Tried copying a file today.
Got unexpected error -50

thanks for the info heliguy, that copy and paste method (rather than move) is always a good idea.

can i check were you trying to do this with imovie, or was it just a file that was somewhere else, and you used finder to copy and paste it onto the drobo? i do not have a mac, but it seems that its a error regarding a user parameter list (not sure that that means exactly, though some web pages seem to indicate its to do with imovie clip programs?)

It was not iMovie. Simply copying large video files. Transfers stalls then crap out whether I’m transferring from a nearby laptop on Wifi, or also a Mac Mini connected via CAT6 ethernet cable to the gigabyte router.

thanks for the clarification,
how easy would it be for you to try the same test, but when connected directly with the 5n and computer?

am just wondering if its the router in any way, or whether the problem still persists even when connected directly?
(is any itunes or other multimedia-related app running in the background that you could check and close if present too, even spotify or even spotlight search indexer?)[hr]
also, can i check how much free space your drobo is showing you as available in dashboard (in value and % free) as well as how much free space the destination drive is showing you in finder?

I went to Best Buy, bought a new Asus RT-AC66R router. Same problems as on my Netgear R6300 router.
Tried connecting 5N directly to my 2012 Mac Mini and directly to my 2015 15" Macbook Pro Retina via Ethernet to Thunderbolt dongle (Both running OS X Sierra).
Tried with supplied ethernet cable and another CAT6 ethernet cable I had.
Nothing helps. AJA Systems Test and blackmagic stall on trying to write to drive and test fails.

Drobo sent me a replacement RMA 5N drive, tried the new one, still the same problem.
Upgraded both drives to latest firmware 3.5.12

Not running iTunes or Spotify or Photos in the background.

7GB free space out of a total of just under 14GB.
All drives are green and reported as healthy in Drobo Dashboard.
In Finder it shows around 60TB free.

I’m at my witts end. I’m hoping I can retrieve the 7GB of data I have on this piece of crap and try to move it to a 5D.

Very disappointed with this product. It’s been a very frustrating experience.

I read in this Synology forum, that there might be a problem with NAS’s from OS X Sierra:

If anyone has any ideas, I’d really appreciate your advice.


ah am sorry the issue is still there,
it is interesting, now that you have tried a different unit, and a different router, is there a way you can try with another computer (which is not sierra), just in case that is the unturned stone, in terms of a next test? (in light of that post you mentioend about sierra and nas devices, it might be good to try if you can?)[hr]
also, maybe there is a way you can try to mount the drobo using a different protocol like a samba connection, or accessing the drobo by an ip address in the meantime?

Booting my 2015 MBP Retina into bootcamp running windows 8.1 same issues.
AJA Speed Test stalls then fails.