Constant green, active light for 3 days

The activity light has been constantly on for the past several days. It doesn’t flicker in the slightest. Access to content on the drive is sluggish. I tried running iostat and ps auxf: there is activity on the drive, but not so high that the Drobo appears taxed nor enough that the light shouldn’t, at least, flicker. And how can I stop it? I tried shutting off most of the apps and making sure that nothing was putting a heavy load on the drive, but that did not change matters. What is it doing? And how do I get it back to “normal”?

[code]# iostat -x
Linux 3.2.58-2 (Drobo5N) 03/19/17 armv7l (3 CPU)

avg-cpu: %user %nice %system %iowait %steal %idle
3.15 22.76 3.41 8.99 0.00 61.69

Device: rrqm/s wrqm/s r/s w/s rkB/s wkB/s avgrq-sz avgqu-sz await r_await w_await svctm %util
sda 16.56 36.75 17.95 19.84 874.41 512.00 25.50 1.25 33.02 44.08 23.02 6.01 22.70[/code]

# ps auxf|grep ' D ' Unknown HZ value! (89) Assume 100. root 337 1.0 0.0 0 0 ? D Feb19 405:35 \_ [dri_dnas_thread] root 1422 1.1 0.0 0 0 ? D Feb19 438:42 \_ [dri_shared_res_] root 1423 1.0 0.0 0 0 ? D Feb19 422:52 \_ [dri_scsi_resp_2] root 3194 0.7 14.4 698960 128272 ? D Mar17 26:28 \_ /mnt/DroboFS/Shares/DroboApps/apache/sbin/httpd -k start -E /tmp/DroboApps/apache/log.txt root 4343 0.6 32.2 606048 286320 ? D Mar17 23:31 \_ /mnt/DroboFS/Shares/DroboApps/apache/sbin/httpd -k start -E /tmp/DroboApps/apache/log.txt root 16634 0.0 0.0 3248 816 pts/1 S+ 12:17 0:00 \_ /bin/busybox /bin/grep D

I’m tempted to use Dashboard to restart, but the last time I did this, the Drobo claimed that the filesystem was corrupted (which turned out not to be the case) and I couldn’t use it for several days, while I tried to understand the downside of resetting the Drobo.

hi wrlee2,
are there any other computers accessing the drobo? for exmaple, maybe windows search indexing or mac spotlight is cataloguing things, or possibly an antivirus scan?

one thing you could try doing, could be to try shutting down each connected computer (or other device like a network device or media tv etc) and then seeing if the activity light goes out when there is nothing on the network which is attached to the drobo.

also, if your drobo is connected to a router which also provide internet, i would disconnect the internet too as a test.
another possible way could be to then wait some more, and then to start unplugging network cables (furtherst away from the drobo, just in case a network cable connecting the drobo to a device, which is not even running, somehow is causing activity?) - this way, the drobo itself it at least still running.