Drobo

Configuring NFS

Can someone help me configure my drobo for NFS?

Hopefully you are sorted. I had the same nightmare. NFS should have been built-in, grrr. I can’t believe NAS makers ignore something so simple, pervasive and useful - especially when linux is the firmware. I run NFS on the last windows boxes we use. Miles better.

The problem is that unfsd is a little different from kernel NFS - it does not seem to recognise the * in exports file. If you can ssh into drobo then the option unfsd -T gives some info as to what is going on. To cut a long long long story short there are in fact other posts on this (which I only found after I’d solved the problem, double grr) -
[align=right]Search for: Can anyone get UNFSD working???[/align]

This is post is for those who, like me, found out how to make NFS work hard way.

[color=#A9A9A9]I would add that there is no real need to restart drobo on each NFS or exports change; if you are delving in drobo innards at this point - by the time I’d finished I had ftp and ssh running - because unfsd provides NFS restart commands in its directory - saves a lot of waiting time.[/color]