Drobo

Configuring FUPPES

Since the previous posts appear to be gone, and this is something people have problems with, I’m reposting my FUPPES instructions.

A little bit of extra discussion can be found here.

DroboFS instructions added 6/2/2010 (Sorry for those having trouble, I’ve been sitting on these for a while):
[list=1]
[]In the FUPPES directory, DroboApps/fuppes by default, open the fuppes.cfg file with WordPad. If you have DropBear SSH installed, ssh to DroboFS and cd to /mnt/DroboNAS/Shares/DroboApps/fuppes. Then use vi to open fuppes.cfg.
[
]Navigate down to the line that starts with <device name=“XBox 360” and change the enabled setting from false to true. This should be around line 199. (This enables 360 support.)
[]In the FUPPES web console, http://:49201/, click the “Configuration” link on the left. On the top of the Configuration page there is a section that’s title “shared objects”. In the field named “Add objects” you want to enter any directories you want to have shared. Each directory must begin with “/mnt/DroboShares/Drobo” in order for it to work. So, for instance, if you have a directory called mp3s, you need to type “/mnt/DroboNAS/Shares/Public/mp3s” in the “Add objects” field. Now press “Submit Query” and continue this process until you have all of your folders added. You can delete a folder by selecting the checkbox next to the folder you wish to delete and pressing “Submit Query”.
[
]Instead of doing the previous step, you can also edit this at the top of fuppes.cfg, in the shared objects setting, add a dir setting for each directory you want to fuppes to share. These directories must be have /mnt/DroboNAS/Shares/Public/ appended to their name. For instance if you have a directory called mp3s, the entry will be “/mnt/DroboNAS/Shares/Public/mp3s/”.
[]Save the file and close it.
[
]Now open vfolder.cfg with either WordPad or vi.
[]Navigate to the line that begins with <vfolder_layout device=“Xbox 360” and once again change enabled from false to true. This should be around line 62. (This creates the file structure the 360 needs to actually display content.)
[
]Save the file and close it.
[]Now open the FUPPES web console by connecting to the IP address of DroboFS at port 49201. For instance mine is http://10.254.25.94:49201/.
[
]Now click the “Options” link on the left. If you’ve already attempted to configure FUPPES you should delete fuppes.db in the FUPPES directory, DroboApps/fuppes/ by default, before proceeding. Once on the Options page select “rebuild database”.
[]This is where it gets a little bit tricky. I’ve seen the FUPPES server die at this point in the process. If you’ve installed DropBear type “ps | grep fuppes”. If the only thing that’s returned says “grep fuppes” then FUPPES is no longer running and you’ll need to restart it. This can be done one of two ways. Your first option is to restart DroboFS. However, if you want to start FUPPES without taking DroboFS offline you can type “/mnt/DroboNAS/Shares/DroboApps/fuppes/service.sh start”. If you haven’t installed DropBear then you should see a fuppes.db file in the DroboApps/fuppes directory. If this file is increasing in size then your content database is being created. If the file never shows up then you’ll need to restart FUPPES by restarting the Drobo.
[]Once FUPPES is finished building it’s database the file will stop increasing in size. You can also keep an eye on the log files to see when it finishes. After this step is finished we need to setup the virtual folder definitions. In the “Options” section of the FUPPES web console select “rebuild virtual container”. Once again this may kill the FUPPES server. See the above process for figuring out if FUPPES is still running. Like before this step will increase the size of your fuppes.db file.
[
]Once your fuppes.db finishes being built you’re good to go. At this point you should be able to turn on your XBox 360 and see your Drobo’s FUPPES server. By default the Drobo will show up with FUPPES in it’s name.
[/list]

    • I’ve noticed that FUPPES will not respond when running in background mode. That means if you’re starting it via DropBear the only way to run FUPPES will cause it to shut down as soon as you disconnect your ssh connection. For the moment it’s probably better to restart DroboFS after you finish configuring FUPPES.

Send me a PM if anyone else has some differences that should be listed. Also I suggest giving MediaTomb a try.

Hi there. I have fuppes installed but am having a big issue. I want it to play flac files which it implies it can. However apparently lame is not included but can I find info on installing lame to the droboapp version? Can I buggery!

Uh, Steps 2 & 5 seem to be missing some pieces of critical information. Can anyone fill in the blanks?

Sorry about that, the site didn’t like my less than signs. I’ve fixed them now.

I installed fuppes per directions aboves. The web config management page is no longer working. I ssh’d into the box and the .db file is no longer increasing in size. Attempting to connect with my PS3, and the node shows up but it says “There are no titles”. What’s a reasonable next step?

I got the ambiguous “no titles” message a lot when I was setting up my PS3 as well, so here’s some things that I tried to get mine working:

  1. Make sure the Fuppes content directory is set to something like “/mnt/DroboShares/Drobo/PS3/”
  2. Fuppes would not show my m2ts files, so I had to rename them to mp4.
  3. Reboot your Drobo, wait about 5 mins and then reboot your PS3.

I am sucessfully streaming Gran Torino 1080p DTS over 802.11n to my PS3 from DroboShare. This movie peaks at around 23.5 Mbps, and the DroboShare kept up with it. I never expected it to after reading many of the negative reviews, so I’m one of the few that are happy with it for now.

I installed the swap memory stuff, rebooted and it worked. Probably was running out of memory.

Any way to configure the database to rebuild every night? I tried finding the chron utility but it doesn’t seem to be installed on the drobo . . . Any help would be great. On the other hand, Does anyone have a precompiled Mediatomb that I could try? I’ve attempted to compile it myself but I’m running into issues with my x64 system.

Thanks!

That’s next on my list of things to tackle. I think you can install cron as an add-on, and then add wget to poke the rebuild page. At least that’s my tentative plan. I’ll post how it turns out.

Awesome. That would really help. I may poke at it a bit as well but I’m definitely not an experienced linux user so any help is appreciated!

Ken

To have a friendly name appear (I use this for my PS3) put

<description_values> <friendly_name>drobo Media Server</friendly_name> <model_name>Free UPnP Entertainment Service</model_name> <model_number>SVN-578</model_number> </description_values>

directly under

<device name="default">

Looks nicer on the dash than “Fuppes SVN-578”

Any luck with the auto cron database rebuild?

Also unrelated but is it possible to have FUPPES send album art that is embedded with the mp3.

I am using the PS3.
Could it possibly be something I need to do in the files cfg file so the PS3 knows there is album art in the mp3?

Thank you to ccalabro for the friendly name work perfectly!

Well, wget is part of the base OS, and there appears to be cron in there, too, but no crontab. I just haven’t found the time to do the research into enabling / using cron on the drobo. If anyone knows how to do this and can post, I’d appreciate it and do the writeup on how to automate a nightly rebuild.

http://www.drobo.com/droboapps/downloads/index.php?id=26

Is this what you’re looking for?

My knowledge of Linux is VERY limited.

Looks like wget on the Drobo doesn’t like accessing the internal web interface for options.html, anyone know if there’s a command line way to update everything? options.html must run some local command

You mean like SSH? There is a Drobo App for SSH and I use Putty to connect to the DroboShare. Hope that helps.

No, don’t mean SSH.

Right now the only command I can find for updated the FUPPES database is through the web interface (which doesn’t want to work through wget), I’d love a way to do it like ./fuppes -updatedb, ./fuppes -rebuilddb and the like.

I downloaded the cron and wget utilitys from the drobo apps website. I’ll try to configure this in the next day or so and post a walkthrough if it works.

Did you have a chance to play with the cron and wget utilities?

I’ve been super busy lately but it’s on my todo list. If someone else get’s this going in the meantime . . .