Drobo

Configuring DroboPorts proftpd-1.3.3d

Hi Ricardo,
I installed proftpd, but the web page isn’t available. It shows up in the list of configuration web pages, but clicking it goes nowhere. Ideas? I’ve messed around but don’t see what the problem is so far.

Have you installed lighttpd and php from the DroboPorts site?

Although it is possible to make it work with the default apache server, the configuration page is setup to work with these packages.

Ah, my bad, that wasn’t clear to me. I’ll try that.

Quick explanation: the version of PHP that ships with the default apache server is utter crap. So, I had to get a new compile of PHP. The problem then became that without the source for the DRI version of apache I couldn’t compile just the module. So I decided to just go ahead and get a modern version of lighttpd, which consumes less memory and is faster than apache on the FS.

OK I got it fired up, and added the proftpd link, however whenever accessing a configuration page (http://MYMACHINE/droboadmin/) it serves up a perfectly blank page. No errors in the logs.

Hello!

I also installed proftpd. FTP login works fine with ftpuser and anonymous, yet, I’m also not able to access the index.php page. It seems that PHP is not serving the file but I did not find anything useful in the logs.

@toolusr did you solve the problem?

Also I did not find out yet how to add another user since ftpasswd is not available.

Thx in advance for any help!

I did not include ftpasswd because it requires perl to run.

You can always download perl from the official DroboApp repository, and ftpasswd from its website.

Thx, that worked!

How-To:

  1. Install perl from the official DroboApp repository and download ftpasswd from its website (as you mentioned)
  2. Copy ftpasswd to /mnt/DroboFS/Shares/DroboApps/proftpd/bin
  3. Set symbolic link: $ ln -s /mnt/DroboFS/Shares/DroboApps/proftpd/bin/ftpasswd /usr/bin/ftpasswd
  4. Set LD_LIBRARY_PATH: $ export LD_LIBRARY_PATH=/mnt/DroboFS/Shares/DroboApps/perl/lib:$LD_LIBRARY_PATH
  5. Set PERL5LIB: $ export PERL5LIB=/mnt/DroboFS/Shares/DroboApps/perl/share/perl/5.10.0:$PERL5LIB
  6. Add both export commands (step 4 & 5) to /etc/profile (optional: correct the TimeZone here if necessary)
  7. Add /bin/false to /etc/shells
  8. get File::Basename from perl-5.10.0, see, and add it to e.g. /mnt/DroboFS/Shares/DroboApps/perl/share/perl/5.10.0/File
  9. Set symbolic link: $ ln -s /mnt/DroboFS/Shares/DroboApps/perl/bin/perl /usr/bin/perl

Optional

  1. restrict access to user home dir (as defined in passwd) add “DefaultRoot ~” to proftpd.conf
  2. to recursively hide hidden files of a certain dir, add to proftpd.conf, e.g.:
<Directory /mnt/DroboFS/Shares/Public>
  HideFiles ^\..*
  <Limit ALL>
    IgnoreHidden On
  </Limit>
</Directory>

Add a user, e.g.:
$ ftpasswd --passwd --name=bob --uid=99 --home=/home/bob --shell=/bin/false --file=/mnt/DroboFS/Shares/DroboApps/proftpd/etc/passwd

Delete a user, e.g.:
$ ftpasswd --name=bob --passwd --delete-user --file=/mnt/DroboFS/Shares/DroboApps/proftpd/etc/passwd

If anyone has further configuration suggestions, please post!

Hi! I think I screwed up BIG time.

I followed the steps, but now my root password for dropbear for me to SSH into the DroboProFS doesn’t work.

I can’t get into my shell… how do I reset the drobo state without losing my data?

I’ve tried userid: root password: root, and that doesn’t work.

I’ve tried userid: ftpuser password: ftpuser and that doesn’t work either.

Did I set some parameters and specify a new root userid and password that I missed out?

I tried to go into the mapped drive for DroboApps in windows, and deleting the Dropbear application, but it doesn’t delete because the files are still running.

It is possible to recover from a misplaced root password. The way to fix this is to use a PHP Terminal. See this post for more information.