Drobo

Catalina Beta Notice about Incompatibility

Just to be aware after updating to Catalina Beta I received a notice that the Drobo extension would be incompatible with a future version of the OS (I assume whatever will be released at virtual WWDC).

1 Like

I got the same message when I just updated to Mac OS 10.15.4. - It would be reassuring if Drobo had something to say about this (and soon),