Can't save documents

I’ve just noticed something odd after I upgraded to macOS Sierra (10.12), I’m not sure it’s related to the new OS, but it’s the only new thing I can think of.

When trying to save a file from a program like Excel, Word, Numbers, Pages, etc. to Drobo the program crashes and doesn’t save the file. I can save to my hard drive without issues.

However, I can copy a file from the Finder to the Drobo drive without issues. And I can open files that are on my Drobo.

I have a Drobo 5N (firmware 3.5.11)

Can anyone help?

hi, can i check if both the computer and drobo have been shutdown, and restarted at least once, since the upgrade?
in case not, could you try that to see if you still get the same problem?[hr]
also, could you try (if possible) using a different network device (just in case it is something to do with how sierra deals with, or connects to network drives)

this may be what you meant, though can you currently also access and open such office documents, from the drobo, but opening them through the program (file open)?
if yes, then what hapens if you try to save that currently open document, back to the drobo, but with a slightly different, and unique name… does it let you save it that way?

Thanks for the suggestion. I did try to save a file from Excel to the Drobo using my son’s Macbook that is still running El Capitan. It worked fine so I think it is Sierra that’s not working quite right with Drobo…

thanks for the info,

there was a note on the login page last week about sierra here:
"The current Drobo Product line is compatible with MacOS Sierra.
The current Drobo Product line includes the following products:

it might be worth raising a ticket with the support team, especially if in warranty, though if something that is meant to be working is not quite right somehow, then they might also possibly appreciate some more of your time too, where possible.

I’ve got the exact same problem my Drobo 5N and a Drobo FS. I can dump any files onto the Drobo fine but as soon as I want to save from Microsoft Word, Excel etc, the application crashes.

@rpuritan was a ticket created for this issue?

I have exactly the same:since upgrading to Sierra last week: can save files directly to Drobo 5N but not through any MS Office product (they hang and a crashed file appears on the Drobo).

Anyone know what is causing this?

I am out of warranty and Drobo Helpdesk is asking to raise and pay for an incident resolution, which I have not done yet.

Same here. Running sierra, Can’t save to Drobo (2.8.3) from Numbers or Pages but can copy file via finder though no problem.

btw another use recently mentioned a method they used, related page here:

maybe that connection method could help you a bit in the meantime?

I am experiencing the exact same issues, we run a small business and keep all of our pages/numbers/etc. on the Drobo, since updating to Sierra last Thursday having major issues.

We can connect, access and open the files from the drobo no issue, as soon as we go to save to the Drobo in pages, numbers we get the pinwheel of death and eventually have to force quit.

In the short term saving everything to our local’s, but still getting some weird behaviour and the odd hang up when saving or moving a file from the drobo.

Extremely frustrated and looking at removing the drobo all together, this is not the first issue we have had between Drobo and Mac.

I see Synology NAS users experiencing same issues, however just read Synology has issued a firmware update that supposedly corrects the issue…I cant even find anything on the Drobo support site other then user threads acknowledging the issue.

And yes have confirmed all firmware, dashboard, etc. up to date as well tried the shut down completely, let sit, re-boot, etc. Nothing is working.

hi pst,
i wasnt sure if you also had a chance to try the suggestion from the linked post above, via titan, though if you get a spare moment, would you be able to try that to see if it helps in the meantime?

Am having the same issue. Cannot save to Drobo 5N from Microsoft Office and other software. Application hangs and requires force quit. The titan “fix” didn’t have any impact. All Drobo dashboard software and Drobo 5N firmware have been updated.

Would love a fix as I’m now forced to use a personal laptop (running on El Capitan) at work in order save files to Drobo.


I have the same issue. Also no problems when running on El Captain. I can move files to the Drobo 5N, but from the moment I open them directly in MS Office, Pages or Numbers and try to save the application hangs. I have opened a call but no update yet.

This is a problem that needs to be looked at.

thanks for trying that out chad, (and its good that you raised a call bart) - hopefully the issue can be resolved for you soon

Are we any closer to finding a solution to this? With my setup it does appear that it is only Apple apps that cause the problems. Adobe for example saves files to the Drobo without issue. Apples Numbers or Pages just hang and then lose their connection to the drive and end up having to be forced quit. I note however the the files are actually saved (in some cases) to the drive but are placed in a newly created folder with the name of the document followed by by a string of numbers.

hi daytona, i was just wondering something…
is there any particular way that your adobe is installed?

for example, if apple made some programs, called Numbers, and Pages, then i could understand if only apple apps had an issue, though i know adobe is a separate company (at least for now), so im just trying to figure out why burt reynolds and chad for example, are having the same issue via Office (which is made by microsoft)?

maybe a temp fix can be found in the meantime, if we can figure out the correlation - such as possibly launching the program from another place, rather than via the Applications section or something similar?[hr]
edit: sorry i meant bart roelands :smiley:

I have given up and am basically transferring MS Office documents to desktop, editing and then storing back onto Drobo. Have gotten used to this and will await the time Sierra. MS Office and Drobo 5N are all compatible again…