Can't Reconnect to Drobo


After much initial wrangling, I was able to get my DroboElite directly connected to a 2008R2 server vis iSCSI (runnong on ESXi 5.5). Last night, I rebooted the server for patches and when it came back up it would no longer connect.

If I connect the drobo via USB, the dashboard can see the device. I’ve tried changing the IP address assigned to the adapter I’m using to both 169.254.X.X and 192.168.X.X (previously, the device was assigned a 10.X.X.X address). The subnetmask and default gateway are the same on the device as they are on the adapter. The IP classes I’m using are not what the rest of my network uses (172.16.X.X).

I’ve also gone into my iSCSI settings and deleted any mention of the drobo out of the computer.

If I manually try to add the drobo via IP, it gives me an error. However, I can ping the device directly.

At this point, I’m completely out of ideas. There is data on this drobo that I do need access to once I can reconnect to the device.


I’m having the exact same issue with my Drobo 5N. I recently installed a new router which gives IPs in a different range from the old router. The 5N gets a new IP, I can ping it just fine and even SSH to it, but it doesn’t show up in Windows Explorer or the Drobo Dashboard, even when I add it by IP.[hr]
I managed to solve the issue. When all the IPs in my network changed, it caused the firewall to freak out.

Try deleting the firewall rules for Drobo Dashboard, DDService and DDAssist. I missed the last two when I tried this earlier. Then add them again and give them full access to the network.

Incase anyone stumbles across this, here’s how I fixed it.

I had added the firewall rules as suggested above, however, the firewall had/has been disabled the entire time.

I removed both network cables, connected just the USB cable, and reconfigured the IP address on one adapter for the network I was connecting to. The other adapter, I left as the default 169.254.x.x (as I initially thought the device would do load balancing, I had both NICs connected to the PC; both were on different networks). After configuring, I rebooted the device. Now, here’s what I think is the key step I wasn’t taking yesterday. I disconnected the USB cable from the back of the drobo (previously, I was virtually disconnecting it from the server but the cable was still physically attached) and reattached the single network cable to the configured NIC.

Once I did that, the drobo software saw the device immediately; all I needed to do was reassign the drive letter through the dashboard.

Thanks to Helgelk for his suggestion; it’s definitely something to keep in mind for the future if I change any network settings.