Can't mount volume but status and capacity look fine in dashboard

I’ve got a gen2 drobo connected via firewire to an iMac (running mavericks). All was working perfectly until a couple of nights ago, I was watching a film from the drobo and it cut off halfway through, since then I can’t get the volume to mount again in osx.

When I look at drobo dashboard the disk pack shows up fine, all four disks have green lights and it reports the correct capacity (2.2TB used out of 4.06TB total). Unfortunately in the Volumes section it just says “Not Formatted” where it used to say “HFS”.

Disk utility shows no volume name at the disk2s2 position, it does report the correct total capacity of the volume (16TB) but I can’t mount it.

I’ve tried several reboots, of both the drobo and the iMac and even tried connecting via USB instead but nothing changes the problem.

Any ideas on what I can do here to get this up and running again?

Sounds similar to my problem, posted here:

Did you get a solution to it?

Seems really frustrating that my drobo has died (with all my data) and it’s not because of a disk dying. Does any one have any ideas how I can fix this?

We might have better advice if we know more about the current state of your Drobo. It seems odd that it would recognize that there’s data, but not present in a volume.

You could open a support case with Drobo and upload a diagnostic log. They can tell you some things which are fine (maybe your Drobo did a filesystem check and found no problems) and what errors exist or what immediately preceded the lost of connectivity.
They won’t fix your Drobo out of a paid support contract, but they can look in the logs.

Disk Utility, try verify and repair.

If still cannot repair, use Disk Warrior to repair file system.

I’m having the exact same problem. Mine happened after a power outage. I can see it in Disk Utility, Disk Warrior, Tech. Tool Pro, and Drive Genius and it repaired and rebuilt one time. After all that it still won’t mount. Same model Drobo too I think.

hi, have you tried powering down completely, (drobo and computer) and waiting for at least 5mins without any power to the drobo, before powering it up again?

a few times in the past, mine wouldnt show up on dashboard (windows) and when i tried that it seemed to do the trick.
(i might have powered up the drobo up to the green lights/blue led boot up sequence, and then the computer, or vice versa)

either way if the dashboard can see it, try to save a diagnostics log as it might point to something in particular?

Was a solution ever found for this problem? I have the exact same problem as OP

Honestly the only way was for me to start all over. I reset everything. I did use DataRescue 4 to save some of my data. It says it is all saved but some of the data is not complete ie some movies are do not work because they freeze. I then salvaged as muxh as I could that way.

Approximately what proportion of your data would you way you were able to recover?