Can't mount share from Mac, mounts OK on Win 7

Wife got a new Mac and we put it on our network (with several Windows 7 machines). Drobo 5N is connected as NAS. Mac did not auto-discover 5N, but connected right away when IP address was entered in Manual Discovery. Viewed from the Mac in the Shares window, three shares exist on the Drobo: XYZ.mac, status Connected (Time Machine enabled); WinBackup, status Connected; and Public, status Available. Trying to check the Mount box for the Public share yields an Error message, “Drobo Dashboard could not mount this share.” The other two shares mounted right away. Permissions are wide open, everyone has read/write permissions, no specific user IDs have been set up. All the Windows 7 machines connect and access files without problems. Any ideas on what I’ve missed?

hi, maybe there is a setting in dashboard, which is specifically for macs?

did you manually connect using this method:

I get the same message if a share is already mounted. Do you have the shares set already in your Preferences-> users -> login Items? They may be mounted but not visible on your desktop due to display preferences

When OSX Starts, we have these shares mount automatically.

One thing to ensure your connection is to make sure you have assigned a static IP address on your drobo (even if you have DHCP address reserved on your router) and then in Drobo Discovery Settings: Enable Auto-Discovery AND create an entry under Manual Drobo Discovery and enable that.

Not only will this reduce your search time when you open Drobo Dashboard, but it also, according to Drobo Support, ensures that your drobo is found on the network (if your router is having a bit of a bad day.)

From here, you should simply see your drobo in your Shared section of Finder. Click on it, and log in as Admin or a user that has access and you should simply be able to click the share to mount and open it.

thanks for more info yfinder,
if your info helps fassmacher fix the problem ,then maybe your forum name should be drobofinder :slight_smile: