Drobo

Can't Get Firefly To Work

Hi,

I’ve just hooked up DroboShare to my Drobo & it’s working fine (installed the latest firmware v1.1.2). I installed Admin Utility & that’s also working fine, however when I install Firefly (and restart etc) although Drobo Admin says the App is installed and ready to be configured, when I click the link my browser tells me that it can’t find the server (can’t connect to the IP address).

Does anyone have any ideas what I’m doing wrong here ?

Thanks,

OK, I’ve worked out what was wrong after Googling across the net for a while. I had to create a folder on Drobo called iTunes, with a subfolder iTunes Music. Then put some MP3’s in there to see if things worked. This time when I installed Firefly via the Drobo Admin App it let me configure things ok. Looks like the config fails if it doesn’t see the expected folder path for the music files. Once running you can go into the config page & set the path for the music files.

However disappointing that Firefly can only serve MP3, M4A, MP4 and WMA files - rules out all my AAC and M4V files :frowning:

Cheers,

Doesn’t work for me - I had the same problem that you had, so I created the folders (I had a well filled iTunes folder already, only not with the “iTunes Music” subfolder, uninstalled Firefly, re-installed it, rebooted DroboShare - but I still get this message that the URL is not responding. Anything else I can do?

Christoph.

The link also from the drobo admin tool doesn’t also work but I’m guessing that until it has indexed your content that the webserver isn’t started.

To change to my iTunes Path rather than moving it around I ended up editing the mt-daapd.conf which is located is in DroboApps/mt-daapd

I’m at the point where I can hear that Drobo is under load and the DroboApps/mt-daapd/db/songs.gdb file is growing.
But nothing to hear or see yet :slight_smile:

Looking at DroboApps/mt-daapd/mt-daapd.log I get:
2019-12-31 00:41:38: Starting rendezvous daemon
2019-12-31 00:41:39: Current database version: 8
2019-12-31 00:41:39: Starting signal handler
2019-12-31 00:41:40: Loading playlists
2019-12-31 00:41:40: Initializing database
2019-12-31 00:41:48: Starting mp3 scan

So maybe in a while it will be complete, not sure why the Time/Date stamp is so far off.[hr]
I my scan ended up finishing off and in the log file I previously mentioned I get a:
2009-08-29 08:09:19: Starting rendezvous daemon
2009-08-29 08:09:19: Current database version: 8
2009-08-29 08:09:19: Starting signal handler
2009-08-29 08:09:20: Loading playlists
2009-08-29 08:09:20: Initializing database
2009-08-29 08:09:22: Starting mp3 scan
2009-08-29 08:10:03: Starting web server from /mnt/DroboShares/Drobo/DroboApps/mt-daapd/admin-root on port 3689
2009-08-29 08:10:03: Registering rendezvous names

and it now works perfectly :slight_smile:
So I would say double check where the config thinks your music is…