Drobo

Can't delete folders on Drobo 5N

Hello everyone. I am having difficulties deleting some folders on my Drobo 5N.

I copied data from several of my fathers Mac computers and external drives for sorting and clearing after he passed away. I have completed that task and moved all worthwhile data where it needs to be. I then tried to delete the folder that housed all the different folders I had copied from the different computers. I got a couple of errors about filenames that were too long. All the files were deleted but there are still 7,382 folders that won’t delete. Computers and Drobo have been rebooted multiple times

I have tried deleting them from Windows 7 and 10 Explorer - nothing happens

Tried deleting them from a Mac computer - told folders cannot be deleted because they are in use.

Tried rd from a DOS prompt and was told the directory wasn’t empy (even went to the bottom level with no subfolders and still got this.

Have tried robocopy from a DOS prompt to fill it with an empty target directory and got an error.

Have tried taking ownership through the Properties menu, and am told I don’t have the Restore priviledge to set myself (admin) as the owner. The current owner is root (Unix User/root).

I’ve read numerous threads on this forum about users connecting directly to the Drobo via USB and running chkdsk, but my Drobo is a 5N and doesn’t have a USB connection only a network.

Would greatly appreciate any suggestions and I will be happy to provide any other details not listed here that would help.

Thanks!

hi lee, usually for mac, diskwarrior is a very good tool, but as far as i know, it does not run on nas product.
when you get a moment, could you try the same properties on that folder, just to see if the count value is still the same, or if it is actually reducing slowly on its own?

can i check if you were trying to delete the folder that you created on the 5n, when the 5n was connected to a mac? maybe shutting down the mac, and also connecting the 5n directly into the windows computer, and trying again might help?
(you might need to also try some more permission/owership granting, via the main admin account on windows that you use too)

btw is your drobo 5n formated mainly for use on windows? for example my drobos use ntfs.

another tip that some users mentioned before, was to remove the share that housed the files and folders you temporarily pasted but ONLY if you had made a new share, and only if you did not need anything else on that share.

Paul,

First off my Drobo is a 5N. It cannot be connected directly to a computer, it only has an ethernet port I mentioned that in my post above.
My Drobo is on an all Windows network. My father had several Macs and several external drives setup with Time Machine. I connected those external drives to each of his machines, and made sure that I had a recent backup. Then I connected those externals via USB to my workstation and moved all the folders from the external to the Drobo. So all these folders were created by my Windows operating system on my main workstation. (Win 7 Professional) As for how the drobo is formatted, I don’t recall formatting it when I set it up. As I said its a 5N and does not work as an attached drive. Only as an NAS through a switch.

As I also said above, I have tried taking ownership of the folder through Windows (my user account is the admin). I have checked the properties of the folder numerous times over the last week and it is constant with the same number of sub folders and zero files.

I have not tried removing the share because my Drobo currently only has one share and it has 3.8 TB of data on it. So I would have to move all that data to a new share just to delete this one nasty folder.

thanks for more info lee,
here are some thoughts (and sorry in case some are not applicable)

  • is windows set to show all files (even hidden or system ones)
  • does windows (or dos) show any hidden, or read only or system attributes on some of those folders?
  • if it finds something which is hidden or system, does the dos attrib -s command work on it or a -r?
  • is there any active virus scanning software running (that might possibly be locking the folder structure while it scans nested subfolders?)
  • does it let you move some of the subfolders, up some levels? (for example, does it let you move the last subfolder into the root of your share?) or does it let you move any random subfolders into the root folder?
  • does it let you rename any of the subfolders, such as the first, last, or random one in the middle? (maybe the filenames are having some special characters and that renaming them to a basic number might help)

Windows is set to show all files even hidden operating system files. When I goto dos and goto the bottom of the folder structure and do a “dir” command it lists . and … as the two dirs and 0 files. When I go up one level and type “rd albums” it tells me that the directory is not empty.

The folders are all set to Read Only in windows properties (unchecking read only and hitting apply doesn’t work. When You re-open the properties window it’s still set to read only.)

I am not sure what -s and -r are supposed to do.

The virus scan has been disabled and the computer has been rebooted with it off and folders still cannot be deleted.

It will let me move any of the folders into any other folders. I can move them up the directory tree, down the directory tree, into the root of the share, I can move it anywhere on the Drobo. But I cannot move it OFF the Drobo.

I can rename folders at the top of the directory tree in the middle and all the way at the bottom. But even after moving or renaming, I still can’t delete them.

ah back on older versions of windows (from 95 i think) people usually had to boot up in a certain way, and then fix a corrupt registry file like user.dat
but the way was to essentially rename user.bak to user.dat, but because windows had it marked as a system or readonly fiile, we had to use the attrib -r to remove the special restrictions, before being able to rename user.dat into user.bad and then user.bak into user.dat and then add the + attributes back in.

then rebooting the computer loaded up the working registry file and all was ok again (until the next time)

thats just why i thought maybe some kind of way of removing those permissions with -r might do the trick…but if not, then i probably have run out of suggestions for now…
(apart from… maybe if you made another share on the drobo, would it let you “move” some of those folders onto the other share, and delete it as part of the end of its move command?) if so, then you might be able to do it like that, and then simply remove the share that now houses only the un-needed files.

alternatively, and while not ideal, if the folders do not actually take up room, then maybe just marking them as hidden, and hiding them out of view could be the way forward until a better fix is found.

Thanks for your help here Paul. I appreciate it. I think you may be correct that the only option is to move the data off of that share and onto a new one. My brother and I are talking about each purchasing a B810n. We will set them up with two shares each. One share is his data, the other share is my data. Then we’ll use the Offsite Data Replication feature for double redundancy. That will be the time to address this uncooperative folder.

ah thanks lee no problem, i hope everything goes well with your future replication plans (and also sorry about your recent event)