Can't Delete Files on OSX

Hello everyone,
I am out of ideas for how to fix my problem and since I didn’t buy into DroboCare, here I am hoping to figure it out. I have been using another archival method to put files that are not accessed all the time onto external hard-drives for off-site storage safely. When I go to remove the files on my 800fs, I keep getting an error stating I cannot erase the file because it is being used somewhere else. I am user Mac OSX 10.11 and have had this problem for awhile now. I am asking since I am getting close to my space limit and have a bunch of things to delete that won’t delete. I am logging into the server as the admin of the 800fs, so I don’t know what else to do.

Hi Clanger1,

Is this what you are doing…

  1. Primary data in a Shared folder in B800fs, and you used a 3rd party Backup App (ChronoSync, CarbonCopyCloner etc) to backup this primary data from the B800fs into a connected external drive on your Mac.

  2. Backup App is installed on the Mac and external drive is direct attached to the Mac as well.

  3. There is a “Scheduled” job or task set in the Backup App that automatic backup (periodically) access the primary data in the B800fs (Shared) into the attached external drive.

Is the above close to what you being doing?

If YES … here’s maybe what is causing the issue…

The “scheduled” task or job from the Backup App is LOCKING the entire folder or data… Try temporarily stop all background backup process and then access the B800i shared and delete the files. See if that works.

Thanks for your response. Here is how I conduct my backups to my 800fs.

OSX - Click and drag from my external work drive (no third party being used to make scheduled backups)
Drobo 800fs #1 is being synced with another 800fs on-site in another buildling - I am using Drobo Sync to make the backup to that drive possible

When I tried to remove these files numerous times, I have tried removing the second 800fs clone from the equation by turning it off and restarting the first 800fs. I have had this drive off for a few days and have cycled through a few shutdowns on my main OSX computer where I am trying to remove the drive.

Do you think Drobo Sync is trying to access the files still? I could try turning off Drobo Sync and see if I can remove the files I need then re-enable it to sync up with the clone? I haven’t done that yet because I was worried it would mess up my clone and I spent about a week building that clone.

Oh you are using DroboSync to replicate Drobo to Drobo backup…

Source B800fs #1 > DroboSync (Rsync) > Dest B800fs #2

  1. from what I know… Dest B800fs will be a total CLONE of Source B800fs #1, down to the ROOT Shares and all the user account from B800fs #1.

  2. B800fs #2 (Cloned) … at the remote site is READ-ONLY… and limited user login. In event of disaster… B800s #1 hit by missile… :stuck_out_tongue: … you can turn B800fs #2 back to “Primary” … and now B800fs #2 is fully accessible … all accounts are able to login etc.

*back to the issue…

a) With DroboSync active between the Source and Dest B800fs.
b) you tried login as Admin using OSX Finder, navigate into a Shared Folder which is residing in B800fs #1 (THE SOURCE). And attempt to delete some files or folders … but failed. OSX said it is locked or in-used.

Is that so???[hr]
I;m still in the thinking mode…

Yes… not good to disconnect or break the exiting Rsync (DroboSync) between the 2 B800fs. If later you turn it back out… it will have to “re-sync” or do all the checksum again … takes a long time…

From what I see… is very unlikely that the current active DroboSync (Rsync) is blocking the files. You should be able to freely delete/move any files even if those files are included in a Rsync process … At least this is what it will be in Linux server or desktop.

Rsync or DroboSync is a sync tool … so it should able to handle deletion of files in the source and sync that changes to the Dest.

And you have already login as Admin to the Shared Folder in the B800fs #1 (Source). with Admin …account, you should have enough permission to delete files.

hi if you are familiar with the mac command line maybe it can also show you which programs are currently using which files.

(a similar tool windows a tool called process explorer, but for mac this page might have a more gui-friendly way)

Yes that is so. I can delete some files in the folder but the folder can’t be deleted. And some files can’t be deleted and folders of files can be deleted. This is the error I am getting…

The operation can’t be completed because the item “filename/folder” is in use.

I am confused, what could be possibly using it? Is Drobosync simultaneously accessing the files and folders as I delete them to initiate a new DroboSync? If so, I should just end up pausing DroboSync and remove everything I need and enable it again? I just don’t want to stop DroboSync and end up deleting my clone 800fs.

I tried researching all of the lsof command and checked out WhatsOpen mac app and that is for Volumes only, not individual files and folders. Is there a way to find out what is accessing each file or folder?

Thanks again for the help! I appreciate it.

ok thanks, i do not have a mac but if find something else i happily let you know,