Can't Access Drobo Apps folder on Win 8.1

Hey guys - I just wanted to start off by saying that I chose a Drobo for it’s simplicity (so I heard) and for the most part, I’m pleased with it. Here’s the recent trouble.

I’ve been running a Drobo 5N for around 5 months now with little issue from my Win 7 desktop machine. I’ve recently moved to a Win 8.1 laptop and can’t seem to access the DroboApps folder in any fashion through my Win 8.1 machine but it’s still working fine through Win 7 desktop. I thought that it may be a user access issue for the drobo, so I shut everything down and started the drobo with just the laptop on the network and the desktop shut off… still no luck. I’ve tried Drobo Dashboard on both and nothing seems to matter. I’d rather not get into the file permissions through putty if I can avoid it, and to be honest, I shouldn’t have to.

I don’t plan on keeping the desktop much longer so I need to sort this issue out before hand.
By the way, accessing the Public folder on the network is working just fine from all computers.
Anything at this point would help. Thanks in advance.

You will need the Drobo Dashboard Admin access for the DroboApps share.
Have you checked that?