Drobo

Cannot remove folder xxx: The directory is not empty

I have a strange problem with Drobo v1 going through a DroboShare. I have two folder that when I try to delete give the error “Error Deleting File or Folder Cannot remove folder xxx: The directory is not empty.” I can rename the folder but not able to remove the folder or the parent folder as a result.

Here is the goofy part though. Somehow these two folders are duplicated in two seperate paths.

  1. Z:\Television\Ongoing\BSG
  2. Z:\Transfer Backup\Television\OngoingTest\BSG
  • I rename the BSG folder in one path (say to Battlestar), the folder in other path updates to reflect that new name.
  • I add a file (asdf.txt) or folder (New Folder) and try to do it in the other I get the prompt the file already exists or New Folder (2)
  • I add the file to either and hit refresh…it disappears. But! If I then try to copy a file or folder with the exact same name of the file that disappeared I get the error about it already existing.

I tried using DOS commands to see contents of folder but it shows it as empty. I tried various dos commands to delete contents (.), no change. I also verified Drobo and Share are up to date. I even waited three days to see if Drobo housekeeping processes might take care of it, but no change.

I thought it was an error related to XP SP3 so googled that and tried things like Unlocker, MoveOnBoot and so forth but no go. I then hooked up a laptop that doesn’t even have the drobo program installed and connected to it using the USB connection. Go to the folder and still get the same error so it seems related to the Drobo and how its “seeing” the folder rather then OS since two different computers have the same error and experience.

Any suggestions?

Connect the Drobo to a Windows machine and run Chkdsk /F on it.

Agreed, just sounds like a double linking thing going on - it is in one folder, just that two other folders think they own it, a simple file system integrity check should clear that right up.

Wow thanks!

That worked way better then expected, it even recovered the documents I thought were lost. I didn’t know that chkdsk would work on it.

glad we could help :slight_smile:

Very happy to hear you got your data back! :slight_smile:

HI guys,

I have the same problem as the original poster but in my case chkdsk does not work- it stops at 60% at Step 3 of chkdsk and freezes. I have let it run the chkdsk over night and it still freezes at the 60% mark.

I am in the process of removing all my data off the Drobo and then doing a format.

Do you think that formatting will fix the problem?

The Drobo has 4 2tb drives so coping the data off it is going to take a long long time.

I tried to use Spinrite but it did not understand the Drobo file system.

Any suggestions would be great.

Thanks!

yes, i do think that formatting will work :slight_smile:

Thanks! I will let you and others know if that does work - it is taking so long to copy data off it…

/cb

Hi People, it took two days to get all the data off the Drobo, but I am happy to report that reformatting the Drobo fixed the chkdsk not completing error.

Thanks

CB

Glad to hear it worked :slight_smile: