Broken FS - Is there any hope?

I have a Drobo FS. It’s been working well enough for the last few years. I accidentally filled a disk set (5 x 6TB drives) and now it’s bricked. It was working fine, I shut it down via Dashboard, put a new set of identical blank drives in, turned it on, and it’s totally undiscovered by Dashboard.

Took the drives out, restarted it. No luck.

Any help would be appreciated here. I know it’s EOL and that means I’m SOL but maybe there is some hope.

I’m using Dashboard 2.6.2 but I’ve also tried 2.5.3, no luck.
I’ve reset the thing with the back reset button.
I’ve directly connected it to my Ethernet, disabled all firewalls and other nonsense…
It WILL give my computer an IP address like it’s supposed to.
But telnet to 5000 and 3260 doesn’t connect. (this is the address given to me by support) Dashboard will not find it.

Support said that if the green light is solid and the yellow light is flashing on the ethernet port then it’s something computer-side blocking it. I’ve tried a few computers and I’m fairly certain it’s not being blocked in any way. It seems like it just isn’t sending meaningful data or isn’t resetting properly.

I have the thing totally apart. Checked the internal battery and so on. Any suggestions? It’s a totally stock drobo FS, no apps or anything. Is there anything to be done here? Perhaps a jumper or something to totally clear the memory?

Can you post some pictures of the motherboard? There might be a serial port somewhere.

J4 J5 J9 J18 and Con1 All show promise but there is nothing obviously labeled as a serial console. I’m a bit weary of just randomly plugging things to a serial port… but I suppose it can’t break more than it is now.

Any thoughts?


Well, technically speaking you can’t break it by just plugging the ground and RX/TX cables. I’d just test the different pins with a multimeter to find out which is the ground and which is VCC. I’m pretty sure that the board runs at 3.3V, so that’s the VCC you should be looking for.

I’d focus on the 4 pin ports, i.e., J4 J5 and J9. If J9 is any indication, the pin closer to the LEDs in the front should be the ground.

From dmesg, we know that the FS has two serial consoles: one for the vxWorks core, and one for the Linux core. If I were a betting man, I’d say that J4 and J5 are the best candidates.

For the next steps you are going to need a TTL->USB adapter. If you are an arduino tinkerer, you probably already have one. If not ebay will be happy to provide you with one. You probably want something like this (first result on search “TTL USB”):

Anything with CP1202 and FT232 will also work. Notice how this model already comes with the connectors for the J4 and J5 connectors.

Findinf out the exact pinout will require a multimeter. Using as reference, these 4 pin connectors are either:

  • [RTVG], i.e., RX, TX, VCC, ground
  • [TRVG], i.e., TX, RX, VCC, ground
  • [VRTG], i.e., VCC, RX, TX, ground
  • [VTRG], i.e., VCC, TX, RX, ground

The first thing you have to do is find ground. I assume it is the rightmost one, but make sure that is the case. Once you have that one, it’ll be easy to find VCC. Tape over that one to make sure you won’t cause a short. Then plug the TX and RX pins in any way you want (if it does not work, switch them around). On the computer I’d try 9600 bauds first, since that is the traditional serial port speed, and then increase up to 115200.

Please let us know if this works, or if you need any further help.

Fortunately I have more Arduinos than I can count and a literal handful of TTL-Serial adapters :slight_smile:

I’ll play with it today and get back to you with anything I find. Thanks for the help so far!

I quoted you so it alerts you of the reply… does this forum do that? I have no idea :slight_smile:

Anyway… I unbricked it. Here’s what I found:

J4 and J5 in that picture are the serial consoles. They are VRTG with Ground closest to the LEDs (good call on that one). They run at 115200 baud. J4 is the vxWorks and J5 is the Linux.

They run at 3.3v so I used a ttl-serial converter.

When I ran it I saw a few error messages saying there was no space left on the device so various logs couldn’t be created and some scripts couldn’t run.

Specifically I saw a few errors of not finding the size of /var/log/nasd.log especially when trying to restart it.

Deleted the file with rm /var/log/nasd.log, restarted the device, and suddenly everything works. Shows up in dashboard and everything. I haven’t put a new set of drives in yet, but I’ll overnight some and try it tomorrow.

Woot! That is amazing. I have added this to the DroboFS non-official knowledge base. To summarize:

  • Both are confirmed 3.3V, TTL, pinout is VRTG -> LEDs, running at 115200 baud;
  • J4: serial console for vxWorks;
  • J5: serial console for Linux;

The wiki page is here (bottom of the page):
I hope you don’t mind if I borrow your picture of the motherboard.

This will help so many people. If you look around in the forums you’ll see that there a lot of old FS’s that are slowly presenting the same symptoms.

I am going to attempt the same thing, since i have one doing the same thing, but have some questions

Do i need to plug in the VCC cable or not,

which port, the linux or the vxWorks

Any help with the commands would be awesome also

Since we know for a fact that it works without a VCC, my recommendation is absolutely not to plug a VCC. At best it won’t help, at worst you could burn the serial port.

For simple recovery, I’d say try first the Linux side, since that is relatively well documented (well, by us users), and the Vx side is pretty much self-healing. Most of the trouble I’ve seen so far comes from the Linux side.[hr]
As for commands, I can recommend having a look at the content and free space on /var. This means:

df -h

… and look for this line:

/dev/mtdblock/2 2.0M 624.0K 1.4M 30% /var

If there is almost no free space left, then remove the contents of /var/log, like this:

rm -fr /var/log/*

trying to connect with putty and I’m not getting anything, I do not have the VCC plugged in[hr]

this is the cable I bought to connect to it, not getting anything on either port

This looks like a proper adapter. The question is whether it is supported by your Windows version. Does a new COM port appear when you plug it it? If so, what is its number? Does putty allow you to connect to that port?

After that, make sure you have it connected properly? Are the RX and TX wires in the right place? Try to switch them, does it work then? As long as you are not plugging VCC anywhere the chances of breaking something are pretty low.

yep shows up correctly and working in windows, com3 115200 baud

putty appears to connect without error

I have tried switching the tx and rx to no avail also

I will try it with a different computer sometime later to see if it it helps any

Did you press a couple of times? By default the console is not outputting much. If it is working you should see a prompt.

Just wanted to say THANK YOU! THANK YOU! I’ve followed the advice on this thread and managed to unbrick my DroboFS !!!

some points that might help other people (they are already in the thred but maybe need some emphasis):

  1. The rx on the drobo linux serial are the tx of the cable (at least for me).
  2. Before you tear your hair out when you can’t see anything on the terminal (I used gtkterm on Linux) take a look at “dmesg” and verify that the recognized /dev/ttyXXXXX is the one you’re trying to read…

Good luck to all and thank you again,


where is the “Like” button?

Is there anyway I could get you to write up a tutorial or ‘how-to’ on this?

1 Like

His solution does indeed work. My DroboFS is unbricked and now alive on my network.

thats interesting…
maybe the /var/log/nasd.log somehow lost permissions and another process or logic rule required it, causing it to hang?
if so, it might be a repeatable fix?

(just tagging this “unbrick” for future searches)

Could use some help
I’m connected, and can see the text, but can’t type.[hr]
Nevermind got it.

So the combo was Black, White, Green, starting with black at the back of the machine towards the fans.
Leaving the red off the front pin, don’t connect that at all.
In the Device manager you have to change the “Bits per seconds” on the Ports settings to 115200
for your USB to Serial. Change “Flow Control” to None on that same tab.
Can check the COM to see which one it’s on while there.

Open up putty and select Serial.
Enter your which COM it is on, from what you found in the device manager.
Change the speed to 115200
Turn on the drobo and you should see text as it’s starting up.

Also, I found /var/log/nasd.log
to be helpful in finding my issue.