Drobo

Boot Looping 5N2

Hey Guys.
Ive had Drobos for 15years+. I have a 4 year old 5N2.
I woke up the other morning to a HDD Failure. Red Warning. 47hours Rebuilding Message.
Bummer. Ordered a new HDD on a 24hour.

Woke up the next day. To the drobvo boot looping. Turns ON. Starts up, starts to rebuild. Turns itself OFF. Repeat the process. Had been doing it all night according to the event log :(.

I have done everything. The ONLY way I can get it to boot up and stay on at the moment is with ALL the HDDs removed. (This allowed me to get a diag report.)

Anything I can do before I purchase Drobo Care? Ofc there is data thats important on it, as normal.
It had 5x 3TB HDDs in it.

Hopefully someone can help!

What drive did you get (Make & model)? It’s actually important given the number of drive manufacturers slipping SMR technology in these days WITHOUT changing drive model names. SMR drives cause Drobos to misbehave, particularly during rebuilds.

Of note though, boot loops are generally down to aging/failing PSUs, it’s always worth trying a replacement.

Hi Cyber! Thanks for firing a reply in!

It failed to rebuild during the rebuild with all the HDDs I put in 4-5 years ago when I first deployed it in my home. Without even putting the new HDD in!

I have a:
Manufacturer code: ST3000VN007

Seagate IronWolf 3TB NAS 3.5" SATA HDD/Hard Drive

To go into it when ready. Wont even fully rebuild and get protected yet. :frowning:

PSU I have not tried. I have the power connectors and can feed it from a desktop power supply with plenty of app headroom. Would this be worth a try do you think?!

When it is on and starts to attempt to rebuild.
After a few minutes. You can hear a HDD power off, then after that they ALL power off. ALL the lights come on. Then after a few seconds off and it reboots. Never seen a Drobo do this before! :frowning:

IronWolf drives are OK, still CMR, so no worries there, different story with the newer BarraCuda drives though.
CMR and SMR Hard Drives | Seagate UK

It’s absolutely worth trying feeding it from a beefy PSU as a test, I use a bench lab supply in such circumstances, but no reason an ATX PSU shouldn’t work as long as the 12v rail has the capacity (hard to find one that hasn’t) & you get the polarity right.

If that solves the issue a replacement power brick is in order.

Tried bench PSU. Tried another Universal laptop psu that I could set to 12v and 8amp capacity (stock one is 7a). Same result. :frowning: So I dont believe its a power issue. :frowning:

Really stuck with this now guys. Started to get a bit concerned about data.

Does the drobo have any kind of data on any built in storage?
While OFF. Removing HDDs, factory reset.
Refit HDDs while off and power up?

Any kind of safe modes or anything I can try?

UM … There’s a read-only mode you can enter by shutting down, ejecting the disk pack, booting, & hitting CTRL+ALT+SHIFT+R to toggle, and shut down again to reinsert the disk pack… Google seems to suggest that in some instances that has cured a boot loop, I’m not sure how much credence I give to the procedure. I guess you might try it, not sure I personally would without support suggesting it.

Trouble is I can’t think of many other options to rescue data before trying things like a factory reset (with associated data loss). There’s companies that sell data recovery software, such as UFS Explorer… or ReclaiMe Pro (neither of which is free or even particularly cheap) which may or may not allow you to recover your data before such drastic action, assuming you have a way to attach that number of drives to your PC, or else there’s scour the market (new or used) for a replacement unit & hope …

There’s no guarantee support can help either, but there’s a choice to be made between gambling on other possible answers, or paying & maybe getting a solution, or maybe being told you need to gamble on other solutions / data recovery software or (expensive) data recovery labs.

Ideally I’d be saying, “try a factory reset/wipe, if it succeeds, restore your backup, if not, replace the unit & restore your backup”.

I’m hitting the limits of what I can offer by way of suggestions at this point… 8 times out of 10, reboot loops seem to be PSU issues… if yours isn’t I’m getting short on new ideas.

IRL if anyone asks me about NAS units (Drobo or other) my response is “Budget for TWO so you can replicate/backup one to the other… RAID is NOT a backup NEVER rely on it.”

Edit: you might get more answers if you also post on reddit r/drobo though I won’t be able to add anything more than I’ve said already, though to be fair, that tends to be just people complaining that Drobo is no good & suggesting people migrate to other solutions, regardless that Drobos are actually no less reliable than many other solutions, however other experienced users exist there who don’t post here. The same might also be true on spiceworks.