Blinking Red lights after multiple drive replacements.

Hi all,

I have a drobo mini that was running 1T/1T/1T/1T just fine for over a year. One drive went yellow, so I replaced it with a 2T, running 2T(a)/1T/1T/1T. After I made that swap, another drive went yellow, so I replaced it with a 2T as well: 2T(a)/2T(b)/1T/1T. Shortly after that, drive (a) started blinking red. I swapped it out: 2T©/2T(b)/1T/1T. Then, drive (b) started blinking red. I swapped it out: 2T©/2T(d)/1T/1T. Now, drive (d) is blinking red again.

The four 2T drives I bought came from two different vendors and are two different brands, it’s unlikely that they’re all bad drives. I’m not sure what the trouble is. Has anyone experience with this? Can you offer any help?

A search through the forums didn’t yield any help, nor did a search through Drobo’s support docs. I found one idea on a related forum that suggested that all of the drives must be working at the same speed. Is this a requirement? My 1T drives are 7200rpm, but my 2T drives are 5400 rpm. Could that be the culprit?

Thanks for all of your help!


hi vincent,
as far as i know, the spin speed might only cause the overall performance to not be as quick or as optimised as it could be, though that it shouldnt really cause drives to fail or flash/blink red.

what may have happened, is that the rebuild process might have put some usage stress on the new drives, which they were not able to properly cope with, and that the new drives (and old) were put through even more repeated usage stress as each subsequent rebuild took place…

if you happen to have a way to connect one of those (currently removed) failed drives in a stand alone way, such as via a usb docking station or caddy case, it might be worth running some drive integrity tests on them. one way could be to use the western digital data life guard tools, and to run all quick and all full surface tests, 1 test at a time, to see if any problems are found there,

if any problems are found, you can hopefully get them RMAd and swapped for repacements,

But, it might be best to start first making some backups of your existing data which is on the mini, especially if it is still currently accessible, just in case another drive happens to fail while you currently already have a failed drive. (while you “could” in theory remove the failed drive if the others are ok and dashboard showing an overall healthy status, apart from that failed drive, any additional rebuild stress might affect some other drives, so i would make a backup if you can, first).

Hi Paul,

Thanks for the advice and suggestions. I backed up my data and then began the process of drive testing. I’m on a mac, so I can’t use the WD app, but I used DriveDX to run the tests. I ran full tests of all drives, and all four drives came back perfectly fine. No errors to report.

Do you (or anyone) have a next step you can recommend? Thanks!

thanks vincent, and am glad your backup successfully completed.
its good that you were able to scan those drives, (and also good to a degree that they all passed that particular check) :slight_smile:

here are some possible options at least from my side in the meantime:

  • you could try raising a ticket with the support team if still within support, as they may be able to help confirm what problems happened by way of some diagnostics logs. (there should still be a way to get a paid-for incident, in case out of support if you would wish)

  • seeing as you have a backup, you could try to see if you have the latest firmware for your drobo, for example via here:
    and then if you remove that flashing red drive (which i think is still inside your drobo),
    and then seeing if the drobo and dashboard recognise the change, and if things are still stable, to try upgrading the firmware. (along with an extra reboot later on of your drobo and computer, on top of any that the upgrading process might include).
    and then if things are still in a stable state, to then try putting that same, previously-unaccepted drive back inside and seeing if it becomes accepted. (it might take some time though).

  • if things are still not working with those drives, then you could try some more drive swaps, such as trying to return the drives that were not fully accepted by the drobo, back to the vendor, hopefully only for a small re-stocking fee that some vendors offer, but trying to get a slightly different model (such as one that is similar to a drive that is working fine for you, with just a larger capacity since you do need more space)[hr]
    btw there is also a webpage here that may help too: