Drobo

Big problems with NFS

Alright… I’m attempting to set up NFS mounts to my droboshares.

The export file looks as default:

/mnt/DroboShares/Pool1 (rw,no_root_squash)
/mnt/DroboShares/Pool2 (rw,no_root_squash)

On my Ubuntu 9.04 server, I’ve added this to my fstab:

192.168.1.23:/mnt/DroboShares/Pool1 /mnt/Pool1 nfs rsize=8192,wsize=8192,timeo=14,intr
192.168.1.23:/mnt/DroboShares/Pool2 /mnt/Pool2 nfs rsize=8192,wsize=8192,timeo=14,intr

Tried manually mounting with -f and -O option… restarting my portmap and nfs-common client… but to no prevail…

It mounts fine and all… but the real problem is once I start doing file actions…

Something so simple as creating a directory over NFS and then trying to CD to it… then I get a Stale NFS file handle error.

Have anyone gotten this to work, and if yes - what does your setup look like?

Hoping someone can help!!

  • Allan Melsen
    Denmark

No help I’m afraid; I’m having the same issue.[hr]

Tried switching from unfsd to knfs, but still no go. The file system doesn’t get exported under knfs. My volume is HFS+ formatted so maybe that’s a factor.

Hi,

I have exactly the same problem, I can mount and all is fine, until I start to access the files, or try anything as fancy as listing a directory… I use EXT3 so it should really not be due to the filesystem on the Drobo?

Did you manage to fix your problem?

Kind regards
Hjalmar