Drobo

Backing up my FS, getting a TON of errors

Hi All,

Maybe someone can help me here.

I’m trying to backup my entire Drobo FS to an external HD using DroboCopy. The external HD is connected to my iMac via USB.

I’m getting a TON of these:

/Volumes/FreeAgent GoFlex Drive/Drobo FS Backup/Jon’s iMac.sparsebundle/bands/1264 – Couldn’t create
/Volumes/FreeAgent GoFlex Drive/Drobo FS Backup/Jon’s iMac.sparsebundle/bands/128a – Couldn’t create
/Volumes/FreeAgent GoFlex Drive/Drobo FS Backup/Jon’s iMac.sparsebundle/bands/1681 – Couldn’t create

Can someone tell me what this is all about? I’m guessing that those are my Time Machine files? Why can’t DroboCopy copy the files to my external HD?

  • Thanx
  • Jon

Couldn’t create usually indicates a permission issue on the file you are trying to copy.

Jon…make sure “ignore permissions” is checked for the FreeAgent GoFlex. You can do this via [Cmd]-i to display the info page for the drive. There should be a check box at the bottom about ignoring permissions. Check that and see if it improves.

Another possibility is if TimeMachine starts running during the DroboCopy. If it does, and TM prunes the backup, you will get the same messages as those bands are no longer part of the sparse bundle. My advice is to disable TM prior to running Drobo Copy and then re-enable it afterwards.

I’ve used Drobo Copy to back up my TimeMachine share from QNAP to Drobo and provided I turned TM off during that time it worked fine.

Thanks for the responses Jennifer and Buzz.

When I look at my FreeAgent GoFlex Drive, under Sharing & Permission, I just see that it says “You can read and write.” There’s no check boxes for permissions.

I just stopped TimeMachine from running, and initiated the DroboCopy backup, and again got the same kind of log file that has hundreds of those errors on the sparsebundle files!

Hm, we haven’t found the issue yet…

  • Jon

Run repair permissions and/or repair disk on the data you are trying to copy.

And if that doesn’t work, please open a support case.

Repairing permissions is akin to Mac voodoo. It only helps if you are having a system problem and then very rarely. I doubt it will help in this situation.

Jon…select the FreeAgent drive on your desktop (single click) and press [Cmd]-I. At the very bottom of the resulting panel should be a check box at the very bottom of the “Sharing & Permissions” section marked “Ignore ownership on this volume”. Click that and see if that helps.

Hi Jennifer and Buzz,

The weirdest thing is that I’m ONLY backing up my Public volume, and NOT my TimeMachine volume. I don’t see any sparsebundle files inside of my Public volume!

I’ve now selected “Delete files in the To folder that are not present in the From folder” and am trying another backup.

Buzz -> Yeah, I have tried that technique several times, and all I get is “You can read and write” under Sharing & Permissions, no check boxes…

  • Jon

That’s odd as I have a Seagate FreeAgent connected to my iMac via FW800 and I see the check box. I’ll check another drive plugged in via USB but it should be the same. Are you logged in as an administrator?

From the initial post it looks like a TM volume but in any case it’s a sparse bundle (“Jon’s iMac.sparsebundle”).

I’ve had trouble moving sparse bundles around, particularly if they are large even from Mac to Mac. I know some other ways to try but none of them are straightforward (rsync and ASR). For rsync you’d need to open Terminal and type “rsync -avzE /Volumes/Drobo\ FS/ /Volumes/FreeAgent GoFlex Drive/Drobo\ FS\ Backup” But I suspect that Drobo Copy is doing much the same thing so the result might well be the same.

ASR would be more involved and would clone the sparse bundle (assuming it’s not a TimeMachine bundle).