B800i - Dashboard intermittent

I have a B800i connected to a Windows 2008 R2 server. Was working fine until I had a drive failure.

I cannot connect to the B800i via iSCSI.

Trying to connect the Dashboard via USB, once a connection is finally established, I can’t view or edit anything in settings. Dashboard finally times out after a few minutes.

I do have a drive that’s failed, but hesitate to do anything with that if the box is on the fritz.


hi, can you see any lights flashing for lots of drive bays, or are they all a solid light (ideally green) and just that particular drive bay which failed, is flashing/blinking red?

also can i check how many blue lights are lit up at the bottom, and what does dashboard show you for used and free space, in values and % when you get a moment?

if nothing else has changed (such as a software upgrade, or firmware update etc), then it could possibly be a faulty cable, or some drive issues, of which 1 seems to have failed, with flashing red light?

if a drive has failed, and if the other drives are flashing yellow/green and rebuilding, then the rebuild process usually takes about 1 day per 1TB of data that you have, but in some rarer cases it has also been known to cause the drobo to be inaccessible to the computer and / or to dashboard sometimes.

it is probably worth creating a ticket with the support team (especially if you are still in support), as they may be able to help confirm in case any other drives are having problems, or in case there is a hardware issue or somesort, (but i think you can still raise a pay per incident, even if out of support, if you would wish)

if nothing is accessible at the moment, then you could try fully shutting down the computer, and then restarting the computer (just in case that makes a difference)

if that does not work, and if no other lights are flashing, and are solid green, then its possible that removing the failed drive (while drobo is on), could alleviate things, and then adding in a blank/empty/uneeded working drive to replace it, (also while on) could initiate a rebuild to use the replacement drive, and then could get things back to a working/accessible state, after that process has comlpeted.

alternatively, you could try shutting all down, and then booting up the drobo (but without any computer connection cables), and then seeing if it goes through the usual boot up sequence with blue lights from 1 through to 10, and then to see if it goes into standby mode.

(if it seems to hang during the blue lights, then please do try to allow lots of time here as it may be self checking or correcting things during this process, but please try to check in case it starts rebooting and looping during its boot up sequence)

once it completes booting up and goes into standby mode (ideally), then you could try connecting it to a freshly-booted computer, with dashboard again… how are things now?

in case the same issue is there, (or especially in the case of a reboot loop) you could try putting the drobo into a readonly mode, for example as mentioned here, to see if things stabilise for you to at least access the data to copy somewhere again, though if you do this before any drive swaps, then please remember to take it out of readonly since it can not actually rebuild when in readonly mode)

Thanks for the ideas…

4 drives in the unit, three sold green lights. I know I have a drive bad, but hesitant to swap it out at this point without a Dashboard that’s working.

No changes. Even pulled the Drobo from the server rack and working with it in my office, so new cable, new power, new workstation to access via USB.

I’ve created a ticket with support, but was provided some generic troubleshooting ideas, none of which were of much use. Figured the Community might have some better ideas.

It’s frustrating that the Dashboard is not accessible to get a better insight to what’s happening. I did have the Dashboard up for a few minutes, but was unable to get to any configuration screens before it failed.

ah it could just be that things were being asked in stages… (i sometimes put all ideas in one go, and then have a followup post saying something like “sorry for the longish post” or something similar :slight_smile:

if dashboard was running fine for a long time (before the drobo was connected), then something seems to have caused it to crash. as far as i remember, dashboard on windows usually self quits when the dashboard service is disabled… but at some point it might be worth disconnecting from the internet, and then disabling any firewall programs, and trying again just in case a firewall update somehow took place since then too, and is adding extra problems…

if you happen to have access to the windows event logs, maybe they can help pinpoint any specific causes too, in case something in windows is causing the problem.

you could also try reinstalling the same version of dashboard, to see if it helps, (possibly also needing to reboot the computer).

what happens if the computer is shutdown, shortly after you have that dashboard crash?
does the drobo remain on as usual (or does it go into standby mode?)
and is the activity light showing activity on the drobo as well?
(and if you also remove the connection cable from the drobo after the computer is shutdown, does that also then trigger a standby mode?)

am just wondering if the drobo does not go into standby mode, after the computer is off, and after the cable is unplugged and say for at least 10minutes?

edit: (sorry for the longish post) :smiley:

A reboot helped, well, kinda.

The Dashboard isn’t crashing, but not behaving correctly. When it actually detects the Drobo (for about 5 minutes or so before it loses connection), I see my volumes and statistics. But I cannot access anything in the menus such as network settings. If I try to access network settings, after a long “please wait…” I get “An error has occurred while loading your previously saved iSCSI settings.” When accessing the general settings, after a long “please wait…” I get “failed to load Drobo settings.”

After about 5 minutes, I loose connectivity to the Drobo and it won’t find it again until I reboot the unit.

One red light and 3 green lights on the drives. Afraid to replace the drive until I get more stability in the system.

Power light green, 3 blue lights on the right.

thanks for more info,
when you got that message about iscsi, was the drobo still connected via usb? (am just wondering what happens if you instead try to connect via iscsi cable?)

it might still be worth trying to reinstall dashboard, or to at least try seeing if the drobo remains recognised when not using your current diskpack…
for example:

  • to shutdown the computer and drobo
  • to remove all connections cables and power from the drobo
  • now while all off and unplugged, to remove all drives from your drobo (remembering the order of your diskpack for later)
  • to then try powering up the computer and dashboard
  • to then try connecting and then powering up the drobo (probably via usb here)
    does it appear as a stable drobo, and remain up and accessible to dashboard for a long time or does it drop access here too?
    WARNING: if it asks you to put a drive in with a red light, please do NOT do that.

instead: to use dashboard to shutdown the drobo

  • to shutdown the computer and remove all power and all connection cables from the drobo

  • to then, with power still all OFF and unpugged, to put your diskpack drives back into where they were before

  • to then power up the unconnected drobo on its own…
    (does it boot up with blue led sequence, from 1 through to 10 and then going into standby mode? if it seems to hang somewhere inbetween, please do allow plenty of time for it to finish)

  • then, if you power up the computer and dashboard

  • and connect the drobo (again via usb) does the drobo wake up shortly after, and become accessible to dashboard, and remain up?
    (if so, can you then shutdown the drobo again, and the computer, and to this time try powering up the computer, dashboard, and then the drobo but this time with iscsi ethernet cable to your computer)

what happens now wildlife?

Well, I think we’re narrowing things down a bit.

The Drobo without any drives seems to work just fine. I don’t have any network settings (all zeroed out), but the unit does not time out, at least for the 15 minutes I tested it.

Drives back in, Dashboard connects, same error messages (“Please wait…” and then “An error occurred while loading your previously saved iSCSI settings”) and then times out after about 5 minutes.

Tells me something. Just not sure what that something is…

hmm this sounds like the main unit (drobo) is still ok
(there would be another kind of test to better confirm this, but that would require the use of 2 different, blank/empty/ or un-needed drives, to essentially create and setup a fresh diskpack on them)

IF at this point, even a freshly-created disk pack was still having problems, and with working drives (that you might have to try at least surface-scanning to confirm), then it could be a faulty unit - though you mentioned yourself that you know you have a bad drive…

and even without dashboard, if all lights were green on the main drobo hardware but 1 was flashing red, the theory would suggest that it can be removed and replaced… (but i guess with fireworks taking place recently, anything that has less chance of something going off with a bang, is probably safer) :slight_smile:

therefore, the safest thing, probably is to fully block-clone each drive, or just the bad one if you and support are in agreement over which drive is bad, (which may take a fair amount of time, but is probably worth it if you can source some spare drives),
and then if you have tried the read-only mode mentioned above, without success, then one thing you could do, could be to power all off, and to remove that failed one (while off), and then to power up to see if it has stabilised.

as far as i know, if there is enough good parity (in terms of working drives) it should continue to boot up (in case the failed drive was causing problems, maybe powerspiking or something internally, sending hardfailure messages back to the main drobo unit which was then holding off the rest of the proper bootup sequence.

if you have not had a chance to try the readonly mode yet, then i would try that first if you can (please remember to exit out of readonly mode when you finish though).

Well, it’s fixed! I finally bit the bullet and replaced the bad drive. With the dashboard not functioning (ie: hanging, non response, etc), I was really hesitant to do anything. But figured what the heck…

Swapped out the drive and was able to start pinging the unit via the iSCSI port. Changed back to the USB and was able to get the Dashboard back up (after waiting quite a long time). Moved the Drobo back to the server (I had been troubleshooting on my laptop) and it came back.

Disappointed there aren’t any other tools except for the Dashboard to work on the unit. Lost a lot of confidence in being able to recover from future problems, but I am happy that the product was resilient enough to keep functioning once the issue was resolved.

Paul - I can’t thank you enough for your support during the past few months. You’re the only one that provided any advice, support, or guidance. That really meant a lot knowing I wasn’t doing this completely alone.

As for Drobo tech support. Pretty useless unless you’re willing to pay them to talk to you. Sad to see yet another vendor that has a great product but crummy support after the sale. Definitely something I’ll remember when I’m making my next purchase.

ah many thanks indeed, wildlife, i do appreciate that :slight_smile:

if things are all working ok now, it is probably best to leave things as they are (or to make some more backups at least of the most important data if possible). and maybe in future trying to update or reinstall dashboard might help it be found again. (for now i would leave things be, just in case theres another issue or future requirement based on iscsi drivers, like some mentioned in the link below, and then perhaps to only try tackling them if another issue arises)

either way, i am glad that you were able to get your drobo drive working again, and data accessible. :slight_smile:
(the only downside to this though, is that now, you cant use “fixing the drobo” as an excuse if the other half want you to do the shopping or the hoovering) :smiley: