Automatic update seems broken?

I’m using a Drobo 5N on Mac OS 10.11.3. My current versions of the 5N firmware and Drobo Dashboard are 3.3.0 and 2.7.0 respectively.

The latest versions are 3.5.5 and 2.7.1 respectively, but when I “Check for Updates” on the Tools page it just gives me the usual “Drobo has the latest versions of the Drobo Dashboard and Drobo firmware.” It seems to check and then pretend there are no such updates.

Is anyone else stuck on these versions? I could try to update both manually, but I don’t know why it doesn’t want to update, and I don’t want to break anything. Does anyone know why this might happen, or if it’s just a bug?

hi is it possible that maybe your internet was not available at that particular point in time?
what happens if you try again now?

My Internet connection is working fine. If I disable my Internet connection and try to check for updates, I get an error, not a message saying I’m up to date. I’ve also tried to check for updates several times over different days. Thanks though.

I am having the same issue. Have had to run manual updates for firmware and dashboard almost ever since i got me drobo. Using OS X 10.10-10.11 (started using drobo on Yosemite and now using El Capitan)

thanks for the clarification, and extra info,
it may be an issue with the update website for the newer firmware, though can i check if you guys are using any apps on your 5n?

Nope, not using any apps on mine. They are disabled.

FWIW I’m using Firmware 3.2.2 and Dashboard 2.6.7 and I’m only being offered automatic updates to versions 3.3.0 and 2.7.0 respectively. That seems to agree with the OP’s point of view. I might update manually or I might just leave things as they are. If it ain’t broke…

thanks john and fletom,

part of me was thinking that maybe certain apps being used (and not being compatible with that firmware might be preventing the apps from being broken, but if apps are disabled for you fletom, then that probably rules that one out)…

some updates for any general software, are sometimes rolled out in stages, such as needing to go from version 1.1 to version 1.2 before being able to go to v1.4 (as opposed to going straight from 1.1 to 1.4), so possibly good to know if any other users currently also on fletoms 3.3.0 version are only seeing the same thing, just in case you (john) are only seeing 3.3.0 and that maybe some others on 3.3.0 are able to see the next version…

… but the good old addage john mentions, is usually pretty good, in the sense that if all is working fine currently (and if no upgrades or drive swapps are planned), maybe good to not rock the boat :slight_smile:

I only have Dropbear installed on mine, so that I can ssh into it.

I had to manually upgrade my new 5N to 3.5.5. I do not think you get automatic upgrades to 3.5.x but I may be mistaken.

I went to updated my dashboard to 2.7.1 and re-enabled my firewall. Then I downloaded 3.5.5 and went to the new dashboard selected tools and picked manual update. That worked without a hitch.

BTW: It is recommended that you back up your data before upgrading your firmware.

thanks for more infos

I am also stuck at Dashboard 2.7.0 and firmware 3.3.0, on OS X 10.11.3.

I can confirm there’s not a notification about 3.5.6 nor 2.7.1. I discovered last ones checking Drobo website.