Attaching 8D with plain vanilla USB

Hello, I know this is dumb, but I’m old school… I just got a Drobo 8D and I am trying to connected to my older Mac that doesn’t have Thunderbolt. I got a usb-c to usb cable, but when I plug it in, it says Thunderbolt not compatible. Is there an adapter I can get at Amazon to make it work on my old mac. Thank you for your help!

No question in a search for knowledge should be looked down on.
To help answer your question, can you advise what is the model of your (old) Mac and its operating system?

27 inch iMac 2011 with firewire and 10.12.6 Sierra. Thanks for the help!

I ordered this hoping it works… https://amzn.to/2YClKHq

Thanks. Your 8D has Thunderbolt 3 ports and you are thinking to connect it to an original Thunderbolt port on your (older) iMac.

The adapter you linked from Amazon ‘might’ work (I could not verify) but it seems to be intended for simple devices not RAID devices - but note that the connection will be to an iMac with only a USB 2.0 port, so the connection speed (if it works) will be slow, and the adapter will heat up and ultimately fail. For the price though it seems worth the investigation!

I believe your iMac has a Firewire 800 port as well? This was the best way (at the time) to provide fast data connection over the newly introduced Thunderbolt ‘1’ which was then essentially just an advanced Mini Display Port. Over successive Mac models these ports have now merged into Thunderbolt 3.

It would therefore be better to identify a way to connect your Drobo 8D Thunderbolt 3 port to the Firewire 800 port, but I have not been able to find an adapter that supports this so far - perhaps this is a Generation gap too far?

1 Like

On Amazon, there is a thunderbolt 2 to thunderbolt 3 adapter, and a firewire 800 to thunderbolt 2 adapter, but one of the reviewers says it won’t connect to a mac with a firewire port. Maybe I should contact drobo about this and find out what they recommend.

I hope OP has solved the problem already, but I offer my comments.

I had a Mac Pro (2013) and it only had TB2 ports. So I bought the Apple TB2 to TB3 adapter.
I worked most of the time, but occasionally the Mac will crash restart suddenly; never knew if it was the OS or the Drobo.
A few years later, I moved to a MacMini (2018) which has TB3 ports, but alas it also experienced odd crashes and restarts. Some say, and I believe, it was due to the drivers and software for the TB3 chips and or its proprietary Apple T2 controller which was acting up. When T2 drivers and OSX was updated to 10.14.4 or so, it stabilized and the crashes went away.
Despite the crashes, 8D volumes and data were reliably intact, save for instances where Time Machine volumes became corrupted and had to rebuild all over. Hope this helps.