Apple Sierra and Drobo B800i FAIL

Ever since the Sierra update i can not find my B800i.
If i connect with USB i can see it.

Did about everything i can do and know…
Normal UTP and Cross cable … nothing

Any tips? Hints ?

hi fritsdebeer,
do you happen to have access to another computer (or another mac which is not on sierra), just to test if the usual connection method is still working on the hardware?

I have a Brand New Mac Pro on Sierra and it’s not seeing the B800i, although it does see our B1200i. I ponied up and bought the Attotech initiator thinking that was the problem. But it didn’t solve it.

The B800i does work on the old Mac Pro, which has Yosemite.

This B800i has been cagey with me over the years, but it is working on the Yosemite machine.

Any advice from the brain trust here?


hi videot,
i think one time you had problems in the past, it was something to do with a slow host ,a hub, and a cable that was faulty…

can i check if you still get the same problem with your B800i, on your sierra, but when connecting to it in the exact same way as your yosomite does? (for example, the same connection method, and same cable) just as a test?

Hi Paul,

Thanks for responding.

You are correct. I did have those issues in the past, but have managed to get passed them now. I got new hubs and replaced the questionable cables. This time around, I also got brand spanking new Cat6 cabling for connections from the computer to the hub. I got 3’ so that I have short runs.

I can (and did, when I ran out of time on Wednesday before the holiday), connect back to the Yosemite machine, using the same cabling and hubs, and everything came up beautifully. Not so much with the new Sierra machine. I can get the 1200i to connect, but not the B800i.

Any ideas?


Oddly, enough, when I connect the B800i, I no longer can access the Internet (via DHCP and our house network).

Disconnect it (or power down B800i) and Internet comes back.


Can anyone make anything of this?

There should be no IP conflicts, since I use a separate network (1.1.1.x) for the Drobos and the Macs that we share with.

Thanks for any help.


PS: I’m thinking more and more about “retro-grading” this machine back to Yosemite. It’s a sheme…brand spanking new Mac Pro…

thanks for more information videot,

for the part about losing your internet…hmm that is interesting… are there any specific ip overites you are using on your b800i? (usually the nas models allow a manual ip to be used, or to allow it to obtain via dhcp but you might need to hook up the b800i via its management port to the computer to see though)

btw is your b800i connecting to your hub (separately) just as your computer is connecting to your hub, separately too?
if so, maybe your hub has numbered ports (such as 4 device ports + 1 for internet), maybe you could swap the computer and the b800i cables, so that the computer is in device port 1 and the b800i is in device port 2 of the hub?)

also is your hub router a gigabit one? (if not, i think the b800i autonegotiates speed to another setting… maybe that is somehow halting the internet). (it might also be worth checking how old your current hubs firmware is - but try to make a backup or export any current settings before updating any hub router firmware in case any current settings are lost)

if your b800i does still work fine with yosemite, that is a good sign that the b800i still works, and while a newest mac might deserve a newer os, i guess though it at least helps a bit the trouble shooting, to least pinpoint things a bit more towards sierra in some way so far.

Hi Paul, thanks again for responding.

I don’t think there are any IP conflicts. My networks for this project are all manual IPs and I keep a list to avoid assigning a conflicting address. For a short period of time, the Yosemite Mac Pro and the Sierra Mac Pro, did have the same address ( but this afternoon, I changed the Sierra over to It didn’t help. But at least now I can keep both machines up at the same time.

The hubs are Gigabit. I have two of them. They’re actually switches, if that makes a difference in this discussion. They’re just little 5 port switches. I haven’t checked the updates lately, though. They all run on the 1.1.1.x network, that I nickname “MediaNet”
Everything is on MediaNet, including our B1200i and as I mentioned above, I have manually set all of the IP addresses.

The grand exception is the B800i. I have placed it on its own network, 1.2.1.x, nicknamed “DroboNet.” Basically, it seems to run better that way. I can’t remember all of the iterations I went through to determine this, but it is quite stable on the Yosemite Mac Pro. The Sierra won’t connect with it whether I have it on 1.1.1.x or 1.2.1.x

I think at this point, I’m going to allow myself to be the guinea pig and downgrade the new Mac Pro to Yosemite to see what happens. I’ve got nothing to lose at this point. I made a backup this afternoon, so it’s ready so far as I concerned. If that works, I may upgrade it to El Capitan.

Thanks again for your help,

Hi Paul,
I have some more information. First of all, it appears as if the Internet droppage occurs when I connect the Mac Pro to the 1.1.1.x network hub. It occurs even if I do not have the Drobos connected to the hub and the Internet comes back as soon as I disconnect the hub. As such, this appears to be outside the scope of this thread and probably the Drobo forums and I do not wish to hijack this thread. If this aspect of the issue interests someone, you can feel free to pm me.

I checked the firmware and it is current. I’ve also rechecked the IP addresses and none conflict.

So, since I am ignoring the Internet issue for now, I am pursuing why the Drobos will not connect. The B1200i will connect and mount at if I log it in manually using the Attotech Initiator (we have the paid version).

The B800i will not connect. I have it connected at two different addresses: and I cannot ping it at which is the address that I can easily connect and mount on the Yosemite machine. (This tells me that the ethernet port is good on the B800i) I can ping it at (which is the second ethernet port on the B800i and therefore also good), but I do not normally connect and mount at that address on the Yosemite machine. (I can’t remember if Yosemite machine won’t connect at that address, or merely runs slower perhaps because its through a hub and not direct like the other–It’s been a long time since I’ve tried that address).

If I try to connect via the Attotech Initiator, I can discover it (3 targets, actually, and I’m not sure which one to use) and add them. However, I am unable to login on either the or address no matter which target I select.

Thanks again for any help or insight you can give.

Take care,

At this point, I think I am ready to roll back to Yosemite.

Rolling back to Yosemite didn’t help. Symptoms are almost identical to that of Sierra.

Some notes:

  1. Had the same issue with the Internet. This time, though, I was given a dialog box for diagnostics to fix the connection. I selected WIFI and within 60 seconds, I was surfing the web AND accessing the 1.1.1.x network!
  2. I installed Java and the Attotech Initiator before installing 2.8.4 drobo dashboard, rebooting between each.
  3. Drobo Dashboard seems to be discovering the B1200i a little faster and easier than before. I also gave it a little help from the Attotech Initiator GUI.
  4. I can ping the port of the B800i but can’t get Drobo Dashboard to find it. I can discover the targets and add them via the Initiator (just like before) and it lists both the and the ports but can’t log then in. It gives a message that says “Login failed: Initiator Error”. This pretty much is the same thing that happened under Sierra.

Not sure where I’m going from here, but it’s the end of the work day, so I’ll probably just move things back to the old Mac Pro.

I’m open to suggestions.

Thanks again,

I found out today that the Attotech Initiator is only supported up to El Capitan. It does not support Sierra.

Since the Drobo Dashboard depends on the Attotech iSCSI Initiator, perhaps this is the basis on which some are having difficulty with Sierra.

As for my status, I am still working through issues with the B800i, though I am getting closer and closer to success. The B1200i is working with no problems.

I will post more, if the solution turns out to be relevant to this thread. If not, and I discover something new, I will post a new thread.

Take care,

ah thanks for more info you’ve been busy trying things out videot :slight_smile:
its interesting that atto does not support sierra (that probably means that they either have not finished working on a sierra version, and do not “yet” support it, or perhaps sierra is not playing nice).

either way, if you do happen to upgrade into el capitan, please only do that with your drobos safely shutdown / off and unplugged, because there have been some known issues where the el capitan upgrade process affects some connected storage devices including drobo. for example as mentioned here:

I have had a similar issue as videot, I have OS Sierra and have been unable to connect to my 800i. Today I was able to get ATTO working and make the drobo connect and mount through ATTO. But drobo dashboard still does not see the 800i. I have tried multiple versions of dashboard but none of them will let me see the 800i.

Is it bad to just bypass the dashboard and mount the volumes through ATTO? I would like to get dashboard working but I can live without it.


thanks for the update on info eanderson,

for kyler, im not sure about the mac, though for windows, i havent had any problems using the drobo without dashboard, (and have been able to use the usb-devices feature to safely remove device before), but i do try to use it if i can, so that i use dashboard to disconnect, but most especially if i know that the drobo is getting quite full, just to make sure that i dont overfill it by mistake. - the blue led lights are good in that regard, but once you get near 9 lights on the physical drobo, only dashboard can tell you the true space remaining.[hr]
generally speaking though, if dashboard works fine, then dashboard is best to be left on, especially if a computer is having programs using the drobo during the day or night etc, so that it can at least pop up an alert for you to see, or to send an email notification etc,