Drobo

Apple/Mac Big Sur Compatabilty: POSSIBLE SOLUTION

Greetings,

I’m a beta tester for Apple. I’m part of the “official” beta testing program called Appleseed. I am not an Apple employee. This is not the public beta or the developer beta. I’m running the second beta release, 11.0 Beta (20A4300b) and my 5D3 will not mount over Thunderbolt 3. It will mount over USB-3, but it is very slow. If your files on your Drobo are mission critical, I do not personally recommend going to Big Sur. This is not Apple’s opinion or Drobo’s opinion, just a user that has official access to the Big Sur beta releases. I hope this helps.

1 Like

UPDATE: Possible Solution

I have solved this issue for my 5D3 on my 2017 27" iMac. I used the uninstaller and uninstalled the Drobo Dashboard. But unbeknownst to me, not all the extensions were removed by the uninstaller. I struggled with this for several weeks until a program called etreCheck (free on Apple App Store) said I had extensions that were not installed. The app pointed me to Mac HD>>Library>>Extensions. There were several kernel extension with the name Drobo and also SCSI and I moved those to the trash and emptied the trash.

I then downloaded a fresh copy of the latest Drobo Dashboard and ran the uninstaller again, figured it couldn’t hurt. I then ran the installer and low and behold, the Drobo 5D3 is now mounted via Thunderbolt 3. I also ran a Speedtest and it’s the same as it was on Catalina.

Disclaimer: I don’t work for Apple or Drobo. Do this at your own risk. I don’t know if it will work for any other Thunderbolt 3 Drobo. Good luck.

Hi - Drobo 5D3 connected to a 2013 Mac Pro running latest Big Sur BETA 3. Tried the above and did not find the rouge extensions after running the uninstaller. Drobo still not recognized when connected via Thunderbolt 3. Old LaCie disk connects fine over TB. Will keep experimenting, etc., but that’s just my situation now. Will update when I get it working. Perhaps with Big Sur BETA 4…