Drobo

Another Gen2 Failure ... ** NOT **

It seems my old Gen2 Drobo was unplugged one too many times. I unplugged and (gently) moved the Drobo out of the way so I could replace my 8-year-old AMD motherboard with a shiny new Intel i5.

Sometimes it goes into a reboot loop; other times it appears to boot normally, but then Windows reports a “USB device failure” and won’t mount. Sometimes the power light is red, other times it is green but all other lights are out. Pin reset didn’t help, neither did starting without drives…just stares at me like “who are you and what do you want”. I tried a different USB cable too. If I leave the USB unplugged and power it up it sometimes acts up, while other times it seems normal until I plug the USB back in.

Nothing critical on it thank goodness. Frustrating for sure, but it is vintage 2008. Anything else I could try?

Just tried it again. If I power up the Drobo first, it completes and goes into standby. Next, when I power on the computer, the Drobo wakes up but then all the drive lights flash red and it goes into a reboot loop. Only thing I haven’t tried yet is plugging the Drobo into a different computer.

hi dragon, sometimes powering up an unconnected drobo first (as you mentioned in that 2nd post of yours) can prep it, and then when the computer is booted, and dashboard is launched (after the computer is fully booted and running), then attaching the usb cable to the drobo can sometimes get things working.

if you have not tried it specifically like that, then if you get a chance does that help at all?

(i had a few issues when my usb ports got locked and i had to fully power all off for at least 5-10mins)

do you have any more usb cables that you could try, and directly attaching them (just in case you were going through any hubs etc) and maybe if there is a different port on your motherboard, you could try plugging it in differently.

another thing that you can try, especially with the reboot loop, is to try putting your drobo into readonly mode, such as mentioned here:
http://www.drobospace.com/forums/showthread.php?tid=143618

(though one thing that springs to mind, is the possibility that the new motherboard, maybe needs some of its usb settings checked, in the bios, just in case the new motherboard’s default drivers or settings are the “variable” that has changed?)

I have tried that, and I usually get a windows pop-up warning of a USB device failure and nothing else happens. It is connected directly, and I did try other USB cables.

Only once since swapping in the new hardware did I get it to come up correctly, but then a computer restart killed it again. I need to try it on a different computer to make sure.

ok hope all goes well…
one other thing you could try, is to boot up windows on its own, but then to wait at the log in screen, and then to attach and power up the drobo, before logging into windows.

you could also try powering all off (and removing all cables from the drobo) and to remove your diskpack
and then to try using it empty (to see if at least dashboard recognises it), as that way it can test the main hardware.

(am sure you already know though please only remove or insert disk packs when power is all off and unplugged)

After plugging the Drobo into another computer and verifying it worked, I went back for another look. In Device Manager I removed the USB drivers and restarted, allowing Windows to re-install the drivers. My Drobo now works fine with no issues!

nice one dragon, thats good to know for a possible fix in future, and also that you got things working again.