All red lights

Hi, I have a situation right now with our drobo fs, it was working well for a while now, and suddenly we started having problems on detecting it in the network, and it became worst, 2nd drive is starting to blink red, took the drive off and put it back again, and it works fine, and now after not using it for a week or two, I turned it back on and all lights are solid red, and the 2nd drive is blinking red, can’t detect it in the network too… any help guys on what can I do…

hi marky can the dashboard still detect the drobo?
if so, and if dashboard is telling you that that particular drive failed, then it may be that that 2nd drive (which was blinking/flashing red) had problems, and when you put it back in, the same problems remained (or got worse).

(usually though, the drobo would refuse a failed drive more quickly than letting it work fine again, but there could be varying degrees of soft-to-hard failures, across the different firmwares.)

if it is still currently having a blinking/flashing red light for that same 2nd drive (and if no other lights are flashing) then you could try removing that 2nd drive, and replacing it another empty/new/blank/un-needed drive if you have one?
(please remember that any drive you replace it with, will lose any data on it, so you may need to back it up before you put it in)

once a new good drive is added, the drobo should go into a rebuild mode with drive lights flashing / blinking yellow and green, and that process usually lasts for approximately 1day per 1TB of data that you have on it.

Helo Paul, dashboard is unable to detect drobo, I tried inserting a new drive but it’s the same, still flashing red. The bigger problem is, only the second drive is flashing red, the rest are just red lights, meaning it’s not a drive failure, it does not even detected all 4 drives… any idea about this?

thanks for the info, here are several ideas of possible ways foward (sorry for a longish post in advance) :slight_smile:

you may have tried this already, though if you try shutting down the computer,
and waiting 5minutes and if no activity light on the fs, to then try unplugging the connection cable
and waiting another 10 minutes to see if the fs still just flashes its 2nd bay light, or if it poweres down in standby mode?
(if it seems as though the drives are still in use via vibrations and the usual chattering sounds they make interally, then please try keeping it on overnight to see how things go)

but if no activity, then you could try the following:

  • to shut down the drobo

  • to remove all drives

  • to power up the (still unconnected) drobo on its own
    (does it power up and then go into standby mode?)

  • to then power up the computer and dashboard,

  • and to then connect the fs to the computer
    (does it wake up and shortly afterwards become recognised via dashboard, usually with a top bay light red? if so, the hardware seems to be working, but please do Not put any drive in even if dashboard asks you to)

  • to then shutdown the drobo via dashboard

  • to then remove all power and connection cables from drobo

  • to then put all your diskpack drives back in

  • to then power up the (unconnected drobo) on its own
    (does it boot up with blue leds, from 1 through to 10, and then go into standby mode? if it seems to hang and need longer to reach 10, please try to give it at least an hour, but try to watch for any reboot loops in case noticable)

what does it do now? if it does seem to complete the boot up stage, but still shows a flashing 2nd bay light which you mentioned before, what are the other drive lights doing and showing?
if they still seem to be the same as before, then please still try to connect the fs to the computer, and to see if the computer and dashboard find the drobo now?

if the problem is still there, then you might be able to try putting the drobo into readonly mode, as mentioned here, to see if it can stabalise things a bit:

another user recently mentioned making some drive clones with a tool here, before trying out more fixes:
(am not sure if you have that or how feasible it would be for you, though worth bearing in mind)

if you do happen to make clones, (by powering all off and removing power and cables, and cloning), then you could also try putting the clones into the drobo and either testing those by powering on, or by putting in all the clones “except” the 2nd bay clone" and then powering on to see what happens (in a mixture of normal mode, and then readonly mode if normal did not work)

it may also be worth raising a ticket with the support team (i think you can still raise a paid ticket even if you are out of support), as the support team may ask you for diagnostic logs at particular stages, and might be able to help pinpoint if any specific drive needs cloning, such as if you only have 1 or 2 spare drives to use as clones, or maybe what could be a problem and possible fix.