All red lights when I upsized a drive

I had all green and 1 yellow light on my drobo S. I went ahead and replaced the 2TB drive with a 4TB drive and then all my lights went red with one flashing (3TB drive) and said I had removed too many drives and to put them back. I replaced the drive I took out with the original one and they stayed all red and one blinking. I then rebooted my drobo and they were all green and the one I tried replacing went red and continued to tell me to replace the drive. After a few minutes all the lights began blinking green/yellow in data protection mode. I believe it is rebuilding now using the old drive 2TB drive. I am waiting till it is out of data protection mode to try replacing again.

How do I replace the new 4TB drive successfully this next go around without getting the all red lights and too many drives removed issue?

Current Drive Sizes: (1) 4TB, (2) 3TB & (2) 2TB

hi marisa, i think if your drobo is currently rebuilding, with flashing yellow and green drive bay lights, then it might need about 1day per 1TB of data that you have on it.

(it might take a little bit more depending on whether anything else is accessing the drobo - and also, in some rarer cases the computer or drobo could possibly lose access to the drobo while rebuilding, but hopefully once the rebuild is complete, all the lights should go back to being a solid colour again, probably all green (except one of them a solid yellow such as the 2TB)

if you can post back at that stage, to let us know how things stand, we can see what options are available

(also we can later check to see if the drives are showing any warning labels, though it would be best not to check that until after the rebuild, in case any drive selections in dashboard cause the rebuild process to start from the beginning again, in a similar way as generating diagnostic logs can).

by the way, if you are still within support, i think it would be good to raise a ticket for the support team if you can, to log the issue, but if you do, please also let them know about this page and your current status of rebuilding, just so that they can be aware of all the info

It’s been rebuilding for close to 40 hours and it looks like I have 4 hours left. Hopefully it will all come back online with all green and the one yellow then I can try a new approach. Unfortunately I don’t have support for this one as I think I have had it for at least 8 years.

OK. I am back to square one with four drives green and one yellow…

  1. Green 4TB
  2. Green 3TB
  3. Green 3TB
  4. Yellow 2TB
  5. Green 2TB

I have a 4TB drive to repave the 2TB one. How should I go about replacing the drive?

thanks for the update marisa,
if you can have a look in dashboard, can you see if clicking on any of the drives (or viewing info via a drop down menu) can show you any more details about the drives (usually things like drive model and firmware etc)… in that area can you see anything to do with the drive health, such as a label saying something like Warning or Healed?

can i also check which drobo you have, (and if you are using single SDR drive redundancy, or dual DDR mode currently?)
and also if you have any other backups of your data?

Ideally, each drive health will not have any issues, but in case any do, (and in case you are only using SDR) i would recommend making backups of your data if you can, (or at least of the most important data) before hand.

if you are using DDR, and have other backups, then what you could try would be as follows:

  • to remove the 2TB drive (as indicated by the solid yellow light)
  • to allow dashboard and drobo a bit of time to recognise the removal
  • and to then put in the replacement drive.
  • dashboard and drobo should shortly after recognise the insertion (though once you do put in the 4TB replacement drive, please allow plenty of time even if it does not seem to be doing anything)

the drobo should hopefully then start doing a rebuild for you (with flashing drive lights of yellow and green) or recognising the new drive and accepting it with a solid green light (but if things look all ok again, please do not try to swap out any more drives, until the drobo has been able to run for at least 1day per 1TB of data that you have on your drobo (just in case it is doing some background relayout tasks)

by the way i think there is still a way to create a ticket for the support team via a pay-per-incident, (even if out of support) if you would wish.

I have the Drobo S. I have all data in another place and because of this I only have single redundancy and I have it partitioned 3 ways with up to 4TB space for each. Information for 2 of the partitions are in 2 other places and 1 partition is only in 1 other place. I am currently using around 8TB of my 9TB available. (I can’t do dual redundancy until I have all 4TB drives)

All software and firmware for the Drobo shows up to date. I can’t seem to be able to see the drives independently, just the 3 volumes labeling the File System, Max Capacity and what is Used. The 2TB & 3TB drives were installed in Oct 2011 and the 4TB drive March 2014. I believe they are all WD black drives, if not the 2&3TB ones might be blue.

When I do the swap do I need to power down at all or leave it on the whole time? I will leave more time in-between each step to allow the drobo to acclimate. The 3TB drive in the second position was the drive that was blinking red during the last go around as an issue.

I have an Apple tower running OSX 10.9.5

thanks for more info marisa, and it is good in general to hear about having backups too,

it sounds like you set up your drobo originally with 4TB max per volume… (that is ok, i set mine up with 2TB volumes as that was what i prefered and needed)

when you do a drive swap, this needs to be while power is still On so that the drobo can recognise the changes, and do anything necessary.

Happy to report the second attempt worked and I now have been upgraded with all green lights!

ah thats great new marisa :slight_smile:

(who needs sherlock holmes when theres a marisa) :smiley: