Drobo

All Red Lights are on

I have been using a Drobo 5D3 for years and have had no issues until now. I had it filled with five WD Red NAS drives (6TBx3 and 4TBx2). I wanted to upgrade the size of on of the 4tb drives so took out one and replaced with 6tb WD Red then all lights turned solid red and drobo says “Warning multiple drive have been removed. Please reinsert removed drives” I only removed one drive. I tried replacing the drive i took out but it still says the same thing. My computer does see that the drobo is attached and drives are present. health status of individual drives say Good.

Help Please

OS: Mac catalina 10.15.7
Drobo firmware: 4.1.4

Your new 6TB WD Red may be an SMR drive or ‘shingled’ drive.


If it is, your Drobo does not support these SMR drives, and this may be the cause.

Ok so I checked and my new drive is a Red Pro which are still CMR

OK noted.
If you still have access to the data, please first make sure you have an updated external copy of your important data?

Following that, please advise what the current array you have in your Drobo - original array or with the new drive?

The data in the Drobo I do not have backed up. The current array is the old configuration. I put the drive I took out back in hopes that it would work again.

I would strongly recommend you set up an external data copy.

Are you able to run Disk Utility on the Drobo from your Mac?

when i open disk utility it does recognize the drobo as Drobo 5D3 - TBMedia however it says uninitialized and shows zero KB

If not already, can you try a simple complete restart of your computer and the Drobo. Turn off and even disconnect the Drobo from its power source, then restart both. If you can, start the computer then the Drobo, and see if it restores you array back to normal?

I tried that but it did not work. Still showing solid red lights and giving the same warning

OK

Assuming you have the latest Drobo Dashboard on your Mac, you could try to activate it without any HDDs and see if you can first regain normal connectivity. But you will need some spare HDDs to then help reset it.

1 Shut down your Drobo completely (even remove the power cord)
2 Remove all your HDDs (note their order and the slots they came from - I would mark them)
3 Restart the empty Drobo to get it to mount on your Mac so it becomes active (and update any firmware).
4 Insert the 2 spare HDDs (small capacity is fine) whilst it is running
5 Let the Drobo format them (all green) and perform a factory reset as well.
6 Shutdown the Drobo (remove power again) and remove the 2 spare HDDs
7 Insert you original HDD array in the original order and slots
8 Restart.

Do NOT remove or insert your original HDDs whilst the Drobo is running or you will lose all data. Hope this proves useful for you to access your original data.

If it does, immediately make an external copy of your important data before attempting anything further.