All Lights Yellow - All capacity lights lit - not mounting

I have had many battles with this Drobo Pro. It mostly sits dormant on my desk because I don’t trust it to do much else. Every now and again, I put some files on it, and then a few days, or weeks later I go to retrieve those files, and what do I find… another problem that requires hours and hours of my life to solve. There’s the backstory.

Today I noticed that all the lights were lit yellow, all the capacity lights are blue, and the activity and power lights are both lit. The Drobo is 8 bays full with 3TB drives, and was sitting somewhere between 30 and 40% full. It was on when I went to access it, and I noticed that it wasn’t mounted, I looked over and saw it in this state. this is a new one, I haven’t seen this before. A quick google found another user who had suffered this a few years ago, so I did what the Drobo moderator advised and unplugged the data cable, and flipped the power switch. It took a few minutes, but it did finally power off. I then unseated all drives, replaced data cable (still iSCSI), replaced power cable, and hit the power button. It booted up, and then went to same light pattern, then shut off… strange, but maybe it fixed itself. Turned it back on, immediately went to same light pattern… Powered off, went to USB, powered up, same light pattern.

I’ve tried another computer, uninstalling and reinstalling Drobo Dashboard, nothing is helping. At this point, as soon as I turn the power on it fires up all of the lights. It won’t mount, and is generally unresponsive. I’m out of warranty, and have had so many trouble tickets on this thing in the past that I’ve probably been flagged. This unit has been fully replaced once before… I recently made sure all firmware, etc. was up-to-date, so that shouldn’t be causing any issues. Not sure where to go from here…


hi tj,
it sounds like youve had some problems with it before which is fair,

im just wondering if you have any more info about the computer you are using to mount it with, and if you have a way to confirm which version of firmware and dashboard you are using? (assuming usb cable?)

the fact that booting it up with no drives, and seeing the same light pattern im not fully understanding sorry…

ive had some interesting time with my original drobo Gen1 before, but after letting it do its stuff overnight, seemed to fix things for me after a power outage.

maybe you can try powering up the drobo with no drives inside (eg you can eject them half way if you dotn want to fully remove them… just DONT push them in with a drobo powered on)
and with no usb cable
and see if the drobo stabalises after waiting a bit.
and then to connect it via usb cable to see if the dashboard can see it etc?

(2nd test is to fully power it off, and unplug the usb cable
and with the power OFF, push all your drives back in / seated etc
and power it on
then if you see led lights, or activity light, just leave it overnight as it might be trying to repair from an issue.
(if youve already tried all this, and for ample time based on how much data you have, then sorry to suggest it again, but i think you might as well try leaving it for enough time just in case it suddenly fixes it for you)

eg upgrading my drives on a gen1/gen2 took a fair few days to do its rebuild and relayout, so whatever seems the norm for your 8 drive system, id give it 1.5 times that amount.

i think one of the guys here doc chris, used to have a whole bunch of drobopros because he liked them so much, and they worked for him, until he upgraded or something, so maybe yours does have a problem, or maybe it just needs more time to fix itself?

hope this helps a bit

It sounds like the chassis is haywire, but I’d try ejecting all the drives and doing a pin reset with the chassis empty to see if maybe it’s just some internal configuration confusion.

I had similar symptoms happen on my old FS. A reset with all drives ejected did the trick for me.

Hi All, I have been having fun the past week with the exact same issue above. I have tried an all drive reset as described above but still my Drobo FS is locked with all drive lights lit and cannot see it in the dashboard. I also tried pulling the internal coin battery out(solution when Drobo is in an infinite reboot loop) leaving the Drobo overnight and then trying to boot up again but with no luck.

I am a bit lost where to go from here, it is out of warranty so no support from Drobo. It would seem I now have a nice door stop!!

Any other suggestions would be greatly appreciated!!

hi, maybe you tried this already, but another test could be the following:

  • to power all off
  • to unplug all drives and computer connection cables from drobo
  • and to power it up empty and unconnected…
    (what does it do now?)

if drobo seems to boot up and go into standby mode, what happens if you power up the computer, and once that is booted up, to attach the usb cable back into the computer?

(please dont put your drives in unless drobo is powered off at the time)