All lights are green but drobo does not show in finder.


Drobo dashboard says everything is healthy. All lights are green but drobo does not show in finder.

I have restarted severals times drobo, connected with usb or firewire.
When i use Disk Utility it gives an error Endcode 8

Diskwarrior 4 also gives me an error

Diskutil repairVolume … error

What do i need to do to restore all my files? HELP plz!

I had exactly the same behavior occur today. I would be grateful if anyone knows what might be going on.

hi, would you both be able to try the following to see if it helps?

  • to use dashboard to shutdown the drobo (where possible)

  • or to at least close down the computer, waiting a few moments, and to then unplug the connection cable, and to let the drobo go into standby.

  • to then power all off and unplug the power cable from the drobo

  • to then remove all drives, remembering the order of your disk pack

  • to then power up the empty, disconnected drobo on its own
    (does it boot up and then go into standby mode?)

  • to then power up the computer, and to then launch dashboard

  • to then connect the drobo to the computer
    (does it wake up shortly after, and become found in dashboad?)

either way, can you then shut all down again, and to unplug all cables form the drobo,

  • and with power all OFF and unplugged, to put your drives back into where they were before,

  • to then power up just the drobo on its own
    (does it boot up with blue led sequence and then go into standby?)

  • to then power up the computer with dashboard again,

  • and to then connect the drobo to the computer (am not sure what model you have but you could try with usb if you have it)
    (does your drobo wake up and become recognised again as before, but more importantly what happens now in terms of your computer finding it?)

Paul -

Thank you for your response…

I ran through the steps as you have outlined them, but it made no difference in the Finder. The steps all completed as you would expect and the disks all come up and the Drobo appears in the dashboard showing everything in good health. But the Drobo still does not appear in the finder.

Any other suggestions? At this point, I am ready to try about anything.


  • Larry

hi larry, thanks for trying those…

can i check does diskwarrior show any errors for you as well, like the original poster mentioned? (when people say they had the exact same issue, i sometimes wonder in case its worth double checking) :slight_smile:

one interesting thing i saw recently, was that some users (on windows), who were essentially not able for dashboard to find the drobo, were able to do this by completely removing/uninstalling dashboard, rebooting, and then reinstalling it again… in your case though, as dashboard does find it, it might be worth trying diskwarrior, but also to simply try connecting the drobo to another separate computer as a test if you can, just in case it does work on your friends mac but not yours (at lease it would help to narrow down the issue)

another option would be to use dashboard while it sees the drobo, to generate a set of diagnostics logs for the support team, (even if only by a 1time paid support ticket in case out of support), as that might yield some results too.

Paul -

I do not have a copy of diskwarrior, but all the other symptoms look the same. The Drobo Dashboard shows all healthy drives and a functioning system, the drive does not mount, and Disk Utility returns an Error Endcode 8. I assume we have the same problem since things up to the diskwarrior point look identical. You are right, I may have judged prematurely.

I tried setting up the drive on another box and got the same result. I can see it in the dashboard and the dashboard reports only happy news, but the drobo does not appear in the finder.

At this point, in the interest of science, I think I can only arrange a support instance to work on this. I want to know whether they can figure out how to retrieve my data (Backed up elsewhere. Whew!) or if I need to do a system reset and whether that will work. The response I have from them indicates file corruption, but failure to mount seems like a pretty drastic result. I tried the drobo as a way to prevent my data disk from becoming my point of failure. It turns out that RAID just moves the problem somewhere else and a single Drobo offers only marginal advantage over a standard drive and possibly no advantage over two mirrored drives.

Thanks again for your help on this.

hi, thanks for more info,

can i check which version of mac you are using?
some other websites mentioned 10.6.8 might read it even if yosemite had problems, but they also mention diskwarrior… i think its worth a try but am not sure if diskwarrior has a free version that could show you if it found a fixable problem (a bit like some other drive tools offer to process the first 10 files unless you make a purchase) - but maybe you could simply ask the makers of diskwarrior if that type of error code might possibly be fixed in a different version to what the original poster mentioned above?

I had the same exact problem - all green in Dashboard but no finder mounting of the drive and I tried on two computers with USB2 and USB3. Tried First Aid in Disk Utility and no joy. Downloaded and paid for Disk Warrior (expensive for sure) but it worked - fille corruption and the file director needed repairing which Disk Warrior accomplished and my Drobo popped up in finder on both Macs. Not sure if Apple or Drobo caused the disruption but I almost freaked when I couldn’t see my stuff. The Drobo has saved me from two harddrive failures but the S/W corruption is a tough one - I do have a single large capacity disk I keep off site but it is about 6 months old.

hi cycle, yes some others have had some issues on newer mac where diskwarrior seemed to get things back again,
ideally things would just continue to work ok, though am glad you were able to get things working again, (and also good that your drobo saved you from some failed drives over time) - i had a drive fail in my 1st gen drobo (which only had single SDR for 1 drive failure) and it was ok again… (apart from now i still have to fix my gen1 but i think some circuitry went as it was attached to a computer which suddenly went out with a power spike or something and they both are still out of action) - but the trusty gen1 served me well for about 6 years :slight_smile: